This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# MikroTik (RouterOS) script for automatically setting DNS records | |
# for clients when they obtain a DHCP lease. | |
# | |
# author SmartFinn <https://gist.github.com/SmartFinn> | |
:local dnsTTL "00:15:00"; | |
:local token "$leaseServerName-$leaseActMAC"; | |
# Normalize hostname (e.g. "-= My Phone =-" -> "My-Phone") | |
# - truncate length to 63 chars |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# jan/29/2018 22: 4:17 by RouterOS 6.41 | |
# | |
/interface list | |
add name=public comment="public network" | |
add name=local comment="local network" | |
add name=guest comment="guest network" | |
# Change the interfaces below to your own | |
/interface list member | |
add list=public interface=ether1 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# DockerHelper.mk is a simple replacement for docker-compose for | |
# working with a single service. | |
# | |
# Usage Examples: | |
# - https://gist.github.com/SmartFinn/7bb86b078726f0763ce0#file-usage-md | |
# - https://github.com/SmartFinn/Dockerfiles | |
# | |
# @author: Sergei Eremenko (https://github.com/SmartFinn) | |
# @license: Unlicense (http://unlicense.org) | |
# @link: https://gist.github.com/SmartFinn/7bb86b078726f0763ce0 |
NewerOlder