To keep the changes from the commit you want to undo
$ git reset --soft HEAD^
To destroy the changes from the commit you want to undo
$ git reset --hard HEAD^
You can also say
function sleep(delayMS) { | |
var start = new Date().getTime(); | |
while (new Date().getTime() < start + delayMS); | |
} |
[user] | |
name = adalenv | |
email = [email protected] | |
[color] | |
diff = auto | |
status = auto | |
branch = auto | |
interactive = auto | |
ui = true |
How to add 2 gateways and seperate clients by Chupaka | |
/ip firewall mangle add chain=prerouting src-address=198.54.15.0/24 action=mark-routing new-routing-mark=r_178 | |
/ip firewall mangle add chain=prerouting src-address=192.168.10.0/24 action=mark-routing new-routing-mark=r_178 | |
/ip firewall mangle add chain=prerouting src-address=192.168.11.0/24 action=mark-routing new-routing-mark=r_172 | |
/ip firewall mangle add chain=prerouting src-address=192.168.12.0/24 action=mark-routing new-routing-mark=r_172 | |
/ip route add gateway=178.242.0.200 routing-mark=r_178 | |
/ip route add gateway=172.16.0.200 routing-mark=r_172 |
find . -name "*.mp3" -newermt "2016-11-07" ! -newermt "2016-11-07" -exec ls -lh {} \; | |
dir ext from date to date command |
<?php | |
function require_auth() { | |
$AUTH_USER = 'admin'; | |
$AUTH_PASS = 'admin'; | |
header('Cache-Control: no-cache, must-revalidate, max-age=0'); | |
$has_supplied_credentials = !(empty($_SERVER['PHP_AUTH_USER']) && empty($_SERVER['PHP_AUTH_PW'])); | |
$is_not_authenticated = ( | |
!$has_supplied_credentials || | |
$_SERVER['PHP_AUTH_USER'] != $AUTH_USER || | |
$_SERVER['PHP_AUTH_PW'] != $AUTH_PASS |
FOR BUILD 3176 | |
----- BEGIN LICENSE ----- | |
sgbteam | |
Single User License | |
EA7E-1153259 | |
8891CBB9 F1513E4F 1A3405C1 A865D53F | |
115F202E 7B91AB2D 0D2A40ED 352B269B | |
76E84F0B CD69BFC7 59F2DFEF E267328F | |
215652A3 E88F9D8F 4C38E3BA 5B2DAAE4 |
#!/usr/bin/env python | |
# -*- encoding: utf-8 -*- | |
# Created on 2018-05-18 09:33:05 | |
# Project: test1 | |
from pyspider.libs.base_handler import * | |
class Handler(BaseHandler): | |
crawl_config = { |
To keep the changes from the commit you want to undo
$ git reset --soft HEAD^
To destroy the changes from the commit you want to undo
$ git reset --hard HEAD^
You can also say
for VE in $(vzlist -Ha -o veid); do vzctl restart $VE; done |
<?php | |
$host = 'localhost'; | |
$user = 'root'; | |
$password = '123456'; | |
$dbname = 'pdoposts'; | |
// Set DSN | |
$dsn = 'mysql:host='. $host .';dbname='. $dbname; | |
// Create a PDO instance |