Skip to content

Instantly share code, notes, and snippets.

View adam-stokes's full-sized avatar
🦧

Adam Stokes adam-stokes

🦧
  • North Carolina
  • 11:22 (UTC -04:00)
View GitHub Profile
matrix:125:load_suites: Parsing /snap/juju-matrix/13/lib/python3.5/site-packages/matrix/matrix.yaml
bus:123:notify: #2 Sat Jan 3 21:59:10 1970:matrix:/snap/juju-matrix/13/lib/python3.5/site-packages/matrix/view.py:265::input_mode:: Attribute(name='origin', default=NOTHING, validator=None, repr=True, cmp=True, hash=True, init=False, convert=None) ui.change
default -> TUIView.show_keymap
view:372:keypress: Resolving method quitter for q
bus:143:notify: Unhandled event Sat Jan 3 21:59:15 1970:matrix:/snap/juju-matrix/13/lib/python3.5/site-packages/matrix/bus.py:158::shutdown:: Attribute(name='origin', default=NOTHING, validator=None, repr=True, cmp=True, hash=True, init=False, convert=None) shutdown
{} 4
bus:146:notify: Exiting Bus with shutdown event
matrix:527:exception_handler: Task exception was never retrieved
matrix:532:exception_handler: {'future': <Task finished coro=<__call__() done, defined at /snap/juju-matrix/13/lib/python3.5/site-packages/matrix/rules.py:547> exception=JujuConnectionError('No curr
diff --git a/conjureup/utils.py b/conjureup/utils.py
index 1b6a0ca..bef94ec 100644
--- a/conjureup/utils.py
+++ b/conjureup/utils.py
@@ -5,6 +5,7 @@ import pty
import shutil
import sys
import uuid
+from pathlib import Path
from collections import Mapping
2017-03-28 19:20:40 ERROR cmd supercommand.go:458 creating hosted model: model "controller" for admin already exists
2017-03-28 19:20:40 DEBUG cmd supercommand.go:459 (error details: [{github.com/juju/juju/cmd/jujud/agent/agent.go:102: } {github.com/juju/juju/agent/agentbootstrap/bootstrap.go:211: creating hosted model} {github.com/juju/juju/state/model.go:379: } {github.com/juju/juju/state/model.go:373: model "controller" for admin already exists}])
2017-03-28 19:20:40 DEBUG juju.cmd.jujud main.go:185 jujud complete, code 0, err <nil>
19:20:40 INFO juju.provider.common destroy.go:20 destroying model "controller"
19:20:40 INFO juju.provider.common destroy.go:31 destroying instances
19:20:41 INFO juju.provider.common destroy.go:51 destroying storage
19:20:41 ERROR cmd supercommand.go:458 failed to bootstrap model: subprocess encountered error code 1
19:20:41 DEBUG cmd supercommand.go:459 (error details: [{github.com/juju/juju/cmd/juju/commands/bootstrap.go:575: failed to bootstrap model} {subprocess encount
Traceback (most recent call last):
File "/home/ubuntu/conjure-up-modelpicker/conjure-dev/bin/conjure-up", line 11, in <module>
load_entry_point('conjure-up', 'console_scripts', 'conjure-up')()
File "/home/ubuntu/conjure-up-modelpicker/conjureup/app.py", line 359, in main
EventLoop.run()
File "/home/ubuntu/conjure-up-modelpicker/ubuntui/ev.py", line 82, in run
cls.loop.run()
File "/home/ubuntu/conjure-up-modelpicker/conjure-dev/lib/python3.5/site-packages/urwid/main_loop.py", line 278, in run
self._run()
File "/home/ubuntu/conjure-up-modelpicker/conjure-dev/lib/python3.5/site-packages/urwid/main_loop.py", line 376, in _run
--- a/landscape/steps/setup-landscape.sh
+++ b/landscape/steps/setup-landscape.sh
@@ -3,4 +3,4 @@ sudo apt-get -qqyf install landscape-api > /dev/null 2>&1
CREDS=$(landscape-api call BootstrapLDS --json admin_email="$LDS_EMAIL" admin_name="$LDS_NAME" admin_password="$LDS_PASSWORD" --uri https://$HAPROXY/api/ --ssl-ca-file /etc/ssl/certs/landscape_server_ca.crt)
export LANDSCAPE_API_KEY=$(echo $CREDS|python -c "import sys,yaml; print(yaml.load(sys.stdin))['LANDSCAPE_API_KEY']")
export LANDSCAPE_API_SECRET=$(echo $CREDS|python -c "import sys,yaml; print(yaml.load(sys.stdin))['LANDSCAPE_API_SECRET']")
-landscape-api register-maas-region-controller --json "http://$MAAS_ENDPOINT/MAAS/" "$MAAS_APIKEY" --uri https://$HAPROXY/api/ --ssl-ca-file /etc/ssl/certs/landscape_server_ca.crt || /bin/true
+landscape-api register-maas-region-controller "http://$MAAS_ENDPOINT/MAAS/" "$MAAS_APIKEY" --uri https://$HAPROXY/api/ --ssl-ca-file /etc/ssl/certs/landscape_server_ca.crt > /dev/null 2>&1 || /bin/true
Traceback (most recent call last):
File "/snap/conjure-up/153/bin/conjure-up", line 11, in <module>
load_entry_point('conjure-up==2.2b1', 'console_scripts', 'conjure-up')()
File "/snap/conjure-up/153/lib/python3.6/site-packages/conjureup/app.py", line 359, in main
EventLoop.run()
File "/snap/conjure-up/153/lib/python3.6/site-packages/ubuntui/ev.py", line 82, in run
cls.loop.run()
File "/snap/conjure-up/153/lib/python3.6/site-packages/urwid/main_loop.py", line 278, in run
self._run()
File "/snap/conjure-up/153/lib/python3.6/site-packages/urwid/main_loop.py", line 376, in _run
File "/snap/conjure-up/150/lib/python3.6/site-packages/urwid/widget.py", line 463, in _emit
signals.emit_signal(self, name, self, *args)
File "/snap/conjure-up/150/lib/python3.6/site-packages/urwid/signals.py", line 264, in emit
result |= self._call_callback(callback, user_arg, user_args, args)
File "/snap/conjure-up/150/lib/python3.6/site-packages/urwid/signals.py", line 294, in _call_callback
return bool(callback(*args_to_pass))
File "/snap/conjure-up/150/lib/python3.6/site-packages/conjureup/ui/views/steps.py", line 43, in done
self.cb(None, None, done=True)
File "/snap/conjure-up/150/lib/python3.6/site-packages/conjureup/controllers/steps/gui.py", line 69, in finish
if utils.is_linux() and step_model.needs_sudo:
ubuntu@ip-172-31-2-43:~$ ./kubectl cluster-info
Kubernetes master is running at https://172.31.23.126:6443
Heapster is running at https://172.31.23.126:6443/api/v1/proxy/namespaces/kube-system/services/heapster
KubeDNS is running at https://172.31.23.126:6443/api/v1/proxy/namespaces/kube-system/services/kube-dns
kubernetes-dashboard is running at https://172.31.23.126:6443/api/v1/proxy/namespaces/kube-system/services/kubernetes-dashboard
Grafana is running at https://172.31.23.126:6443/api/v1/proxy/namespaces/kube-system/services/monitoring-grafana
InfluxDB is running at https://172.31.23.126:6443/api/v1/proxy/namespaces/kube-system/services/monitoring-influxdb
To further debug and diagnose cluster problems, use 'kubectl cluster-info dump'.
Kubernetes master is running at http://localhost:8080
Heapster is running at http://localhost:8080/api/v1/proxy/namespaces/kube-system/services/heapster
KubeDNS is running at http://localhost:8080/api/v1/proxy/namespaces/kube-system/services/kube-dns
kubernetes-dashboard is running at http://localhost:8080/api/v1/proxy/namespaces/kube-system/services/kubernetes-dashboard
Grafana is running at http://localhost:8080/api/v1/proxy/namespaces/kube-system/services/monitoring-grafana
InfluxDB is running at http://localhost:8080/api/v1/proxy/namespaces/kube-system/services/monitoring-influxdb
To further debug and diagnose cluster problems, use 'kubectl cluster-info dump'.
File "/snap/conjure-up/x1/lib/python3.6/site-packages/urwid/main_loop.py", line 278, in run
self._run()
File "/snap/conjure-up/x1/lib/python3.6/site-packages/urwid/main_loop.py", line 376, in _run
self.event_loop.run()
File "/snap/conjure-up/x1/lib/python3.6/site-packages/urwid/main_loop.py", line 1328, in run
raise self._exc_info[0](self._exc_info[1]).with_traceback(self._exc_info[2])
File "/snap/conjure-up/x1/usr/lib/python3.6/asyncio/events.py", line 126, in _run
self._callback(*self._args)
File "/snap/conjure-up/x1/lib/python3.6/site-packages/urwid/raw_display.py", line 393, in <lambda>
event_loop, callback, self.get_available_raw_input())