- An Enumerable of Rubyists @raganwald
- An Indentation of Pythonistas @raganwald
- A fold of Haskellers! @ReinH
- A Din of Twitterers @raganwald
- A callback of JavaScripters @irvingreid
- An NCC-1701 of Java Programmers @raganwald
- A relation of SQLers @raganwald
class Babby < PragnentGirl::GetPragnent | |
attr_accessible :name, :mother, :location, :pragnent_girl_id | |
belongs_to :pragnent_girl | |
before_save :destroy_instain_mothers | |
after_save :pary_for_father | |
#How is babby formed? |
import Control.Monad.Reader | |
hello :: Reader String String | |
hello = do | |
name <- ask | |
return ("hello, " ++ name ++ "!") | |
bye :: Reader String String | |
bye = do | |
name <- ask |
{ | |
"name": "fish.pufferfish.raw", | |
"id": 206, | |
"icon": "fish_raw_puffer_fish", | |
"use_animation": "eat", | |
"use_duration": 32, | |
"max_damage": 0, | |
"stacked_by_data": true, | |
"food": { |
RFC: A more Perl6-esque "unpack" | |
================================ | |
This is an idea for an "unpack" replacement. The basic reasoning behind it, is | |
that number encodings and string encodings needn't be treated all that | |
differently. Instead of passing the name of a string encoding, you can pass | |
a native type object. When decoding things of determinable lengths, any number | |
of types can be given. | |
A variable length thing without a length indication can only be passed at the |
- 2b2t.org - Official Homepage
- reddit.com/r/2b2t - Subreddit
- 8ch.net/2b2t - 8Chan /2b2t/ Board - Founded 20 Sept 2014
- JamesRustles.com - The 2b2t Blog - Founded 15 Dec 2014
On why stateful code is bad | |
=========================== | |
STUDENT: Sir, can I ask a question? | |
TEACHER: Yes! | |
STUDENT: How do you put an elephant inside a fridge? | |
TEACHER: I don't know. | |
STUDENT: It's easy, you just open the fridge and put it in. I have another question! | |
TEACHER: Ok, ask. | |
STUDENT: How to put a donkey inside the fridge? |
/** | |
* static_block.h | |
* | |
* An implementation of a Java-style static block, in C++ (and potentially a | |
* GCC/clang extension to avoid warnings). Almost, but not quite, valid C. | |
* Partially inspired by Andrei Alexandrescu's Scope Guard and | |
* discussions on stackoverflow.com | |
* | |
* By Eyal Rozenberg <[email protected]> | |
* |
One of Larry's purported factors in the design of Camelia (and by extension, Perl 6) was to appeal to 7 year old girls (and by extension, people new to programming in general).
In addition, another design principle of Perl6 was to make it "less Unix centric". Whereas Perl had s///
and tr///
, Perl 6 retains these but adds subst
and trans
, which is friendlier to new programmers, and self-documenting to some degree.
It seems odd, then, that we still have the grep
operator named so. Even in Perl, grep - as in globally search a regular expression and print - bears little resemblance to what it actually does. It's more of a filter, filtering elements out that do not evaluate True to a given expression.
What then would be it's alternative friendly name? Taking into account these design principles...
- Context Sensitive: A term or symbol might do different things in different context