This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope CurrentUser | |
Invoke-RestMethod -Uri https://get.scoop.sh | Invoke-Expression | |
winget install --id Git.Git -e --source winget | |
scoop add bucket extras | |
winget install --id=FluxCD.Flux -e --accept-source-agreements | |
winget install -e --id PuTTY.PuTTY --accept-source-agreements | |
winget install -e --id mRemoteNG.mRemoteNG --accept-source-agreements | |
winget install --id=Fortinet.FortiClientVPN -e --accept-source-agreements |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# feb/11/2022 11:00:55 by RouterOS 7.2rc3 | |
# software id = 9QK9-C798 | |
# | |
# model = RB5009UG+S+ | |
# serial number = XXXXXXXXXX | |
/ip settings set allow-fast-path=no | |
/interface bridge add admin-mac=FF:FF:FF:FF:FF:FF auto-mac=no name=bridge |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/interface bridge add auto-mac=no name=bridge | |
/interface bridge port add bridge=bridge interface=ether1 | |
/interface bridge port add bridge=bridge interface=ether2 | |
/interface bridge port add bridge=bridge interface=ether3 | |
/interface list add name=WAN | |
/interface list add name=LAN |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<# | |
.SYNOPSIS | |
Virtual Desktop Optimalization Tool (VDOT) | |
.DESCRIPTION | |
Download the Virtual Desktop Optimalization Tool (VDOT), creates a folder called optimize and runs VDOT tool. | |
The VDOT tool determines OS version at run-time | |
.NOTES | |
Version: 1.0 | |
Author: Ivo Beerens | |
[email protected] |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Requires $env:AdminUser $env:AdminPassword | |
Set-ExecutionPolicy Bypass -Scope Process -Force | |
iex ((New-Object System.Net.WebClient).DownloadString('https://chocolatey.org/install.ps1')) | |
Enable-WSManCredSSP -Role Server -Force | |
Enable-WSManCredSSP -Role Client -DelegateComputer * -Force | |
New-Item -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\CredentialsDelegation -Name AllowFreshCredentialsWhenNTLMOnly -Force | |
New-ItemProperty -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\CredentialsDelegation\AllowFreshCredentialsWhenNTLMOnly -Name 1 -Value * -PropertyType String | |
$user = "$($env:computername)\$($env:AdminUser)" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
name: Wiki Search Demo | |
description: Wiki Search Demo | |
host: POWERPOINT | |
api_set: {} | |
script: | |
content: | | |
$("#run").click(run); | |
function run() { | |
Office.context.document.getSelectedDataAsync(Office.CoercionType.Text, (asyncResult) => { |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
name: Simple Currency Converter | |
description: Simple currency converter | |
host: EXCEL | |
api_set: {} | |
script: | |
content: > | |
/* | |
* Copyright (c) Riwut Libinuko. All rights reserved. Licensed under the MIT license. | |
*/ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
name: ScriptLab Search Wiki | |
description: Search Wikipedia based on the selected text. | |
host: POWERPOINT | |
api_set: {} | |
script: | |
content: | | |
declare var moment: any; | |
$("#search").click(run); | |
async function run() { |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<?xml version="1.0"?> | |
<configuration xmlns:xdt="http://schemas.microsoft.com/XML-Document-Transform"> | |
<system.webServer> | |
<proxy xdt:Transform="InsertIfMissing" enabled="true" preserveHostHeader="false" | |
reverseRewriteHostInResponseHeaders="false" arrResponseHeader="false"/> | |
<rewrite> | |
<allowedServerVariables> | |
<add name="HTTP_ACCEPT_ENCODING" xdt:Transform="Insert" /> | |
<add name="HTTP_X_ACCEPT_ENCODING" xdt:Transform="Insert" /> | |
<add name="HTTP_X_ORIGINAL_HOST" xdt:Transform="Insert" /> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
using System; | |
using System.Text; | |
using System.Web; | |
namespace Custom.ServerModules | |
{ | |
public class CustomHttpHeaderModule : IHttpModule | |
{ | |
public void Init(HttpApplication context) | |
{ |
NewerOlder