VboxManage list usbhost
VBoxManage controlvm usbattach <uuid>|<address>
VBoxManage controlvm usbdetach <uuid>|<address>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
config interface 'loopback' | |
option ifname 'lo' | |
option proto 'static' | |
option ipaddr '127.0.0.1' | |
option netmask '255.0.0.0' | |
config interface 'lan1' | |
option ifname 'eth0.1' | |
option proto 'static' |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/sh | |
# 定义进出设备(IDEV 内网接口, ODEV外网接口) | |
IDEV="br-lan" | |
ODEV="pppoe-wan" | |
# 定义总的上下带宽 | |
UP="7.52mbit" | |
DOWN="9.55mbit" |
/etc/config/easycwmp
config local
option interface wlan0
option port 7547
option ubus_socket /var/run/ubus.sock
option date_format %FT%T%z
option username bob
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/sh | |
# Wonder Shaper | |
# please read the README before filling out these values | |
# | |
# Set the following values to somewhat less than your actual download | |
# and uplink speed. In kilobits. Also set the device that is to be shaped. | |
# All config needs to be done in /etc/config/wshaper | |
#. /lib/functions.sh |
###Install
opkg install lighttpd lighttpd-mod-cgi
###Configgure
修改/etc/lighttpd/lighttpd.conf
- 行
static-file.exclude-extensions = (".php", ".pl", ".fcgi")
改成static-file.exclude-extensions = (".php", ".pl", ".fcgi", ".lua")
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
# inotifywait-cmd.sh | |
# | |
# Example: | |
# inotifywait-cmd.sh test/ 'phpunit --verbose test/ModelReferencesTest.php' | |
# | |
# Requires: https://github.com/thekid/inotify-win on windows | |
# | |
# author: Gabe LG <[email protected]> |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
pandoc --to=docx -o document.docx wiki.md |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
//From http://stackoverflow.com/questions/25384796/can-i-set-gulp-livereload-to-run-after-all-files-are-compiled | |
var gulp = require('gulp'); | |
var jade = require('gulp-jade'); | |
var gutil = require('gulp-util'); | |
var stylus = require('gulp-stylus'); | |
var jeet = require('jeet'); | |
var nib = require('nib'); | |
var uglify = require('gulp-uglify'); | |
var livereload = require('gulp-livereload'); |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
# usage ./notify.sh [path to folder] [command line to execute on change] | |
while true | |
do | |
set -e | |
inotifywait -q -r --exclude ".git|.idea" -e close_write,moved_to,create $1 > /dev/null | |
set +e | |
eval ${*:2} |