CHR_VERSION=7.16.2
INSTALLPATH=/dev/vda
apt-get update &&
apt-get install -y unzip wget pv coreutils &&
wget https://download.mikrotik.com/routeros/${CHR_VERSION}/chr-${CHR_VERSION}.img.zip &&
unzip chr-${CHR_VERSION}.img.zip &&
echo 1 > /proc/sys/kernel/sysrq &&
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#define _CRT_SECURE_NO_WARNINGS | |
#include <windows.h> | |
#include <string.h> | |
#define POSTCUT ".exe" | |
#define POSTFIX ".original.exe" | |
HANDLE hProcess = INVALID_HANDLE_VALUE; | |
BOOL WINAPI HandlerRoutine( DWORD dwCtrlType ) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#include <arpa/inet.h> | |
#include <netinet/ip.h> | |
#include <netinet/ip_icmp.h> | |
#define PACKETSIZE 64 | |
struct icmp_echo { | |
u_char icmp_type; | |
u_char icmp_code; | |
u_short icmp_cksum; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
:local EthMonitor "ether3" | |
:local EthTurnOff "ether1" | |
:local EthTurnOffStatus [:interface ethernet get $EthTurnOff disabled] | |
/interface ethernet monitor $EthMonitor once do={ | |
:if ($status = "link-ok" && $EthTurnOffStatus ) do={ /interface ethernet set $EthTurnOff disabled=yes } | |
:if ($status != "link-ok" && !$EthTurnOffStatus ) do={ /interface ethernet set $EthTurnOff disabled=no } | |
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
// https://github.com/deemru/w8io/tree/15842edd4235bd3eabc127deac61195257e351ba | |
// https://github.com/GoogleChrome/puppeteer | |
// ffmpeg -framerate 30 -i "w8io_(%%d).png" -c:v libx264 -preset slow -crf 16 -vf fps=30 _w8io.mp4 | |
// https://www.youtube.com/watch?v=n7A-KQ15ynY | |
var promises = []; | |
var maxBrowsers = 8; | |
var maxPromises = maxBrowsers; | |
showtime(); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
call "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Auxiliary\Build\vcvarsall.bat" x64 | |
set WORKDIR=%~dp0 | |
set WORKDIR=%WORKDIR%ton-support\ | |
if not exist "%WORKDIR%" mkdir %WORKDIR% | |
set ZLIBPATH=%WORKDIR%zlib-1.2.11 | |
set ZLIBLIBPATH=%ZLIBPATH%\Release\zlibstatic.lib | |
set ZLIBSOURCE=https://zlib.net/zlib1211.zip | |
if not exist "%ZLIBLIBPATH%" ( |
apt update && apt install -y autoconf libtool build-essential
git clone https://github.com/deemru/libsodium
cd libsodium
autoreconf -fvi
CFLAGS="-DED25519_NOSHA512SK" ./configure
make
Never copy and paste commands that you do not understand or that were given to you by unknown people. This can be dangerous for your system, your security and your privacy. You can accidentally delete important files, get infected by a virus, give access to your data or do other unwanted actions. Always check and learn the commands before running them and use reliable sources of information.
- Debian (or similar OS)
- Login as
root
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
{-# STDLIB_VERSION 6 #-} | |
{-# CONTENT_TYPE DAPP #-} | |
{-# SCRIPT_TYPE ACCOUNT #-} | |
let WAVES = unit | |
let PRECISION = 1_000_000_000_000_000 | |
let kNODE = "NODE" | |
let kLEASEID = "LEASEID" | |
let kLEASED = "LEASED" |