This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
class TileWithNeighbours | |
@@instances = [] | |
attr_accessor :instances | |
def initialize(filename, **neighbours) | |
@filename = filename | |
@neighbours = neighbours | |
@@instances << self | |
end | |
attr_accessor :filename | |
attr_accessor :neighbours |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
function switch_branch() { | |
for branch in master f/fast_find | |
do | |
git -C ~/.vendor/detect_virtualenv checkout $branch >/dev/null 2>&1 | |
. ~/.vendor/detect_virtualenv/detect_virtualenv 2>/dev/null | |
$@ $branch | |
done | |
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
1:v!`*5*54p2*62*77,*5< | |
v _@>v >v>:#<.>1+:2^ | |
>:3%|>:5%|> 1#^_^ | |
v"z"<pvv<"p | |
:>v>v2,"-z2 | |
"",8**,B5"* | |
iF,622#"::4 | |
"",,3*^<^<3 | |
>^>^>^>,8#^6#*< |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
" [email protected]:tpope/vim-pathogen.git | |
runtime bundle/vim-pathogen/autoload/pathogen.vim | |
execute pathogen#infect() | |
" [email protected]:altercation/vim-colors-solarized.git | |
set background=dark | |
colorscheme solarized | |
" [email protected]:ctrlpvim/ctrlp.vim.git | |
let g:ctrlp_map = '<c-p>' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/ip dhcp-server network | |
:local domain "default" | |
:do { :set domain [ get [ find where $leaseActIP in address ] domain ] } on-error={} | |
/ip dhcp-server | |
:local ttl [ get [ find where name=$leaseServerName ] lease-time ] | |
/ip dhcp-server lease | |
:local name | |
:do { :set name "$[ get [ find where server=$leaseServerName && address=$leaseActIP && mac-address=$leaseActMAC ] host-name ].$domain" } on-error={} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
def prompt(text=[]) | |
text = [text].flatten | |
text.unshift('>').push(nil) # for trailing space | |
print text.join(' ') | |
return gets | |
end | |
def counter(maxcount) | |
numbers = [] | |
for i in maxcount |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
blake = "some guy" | |
Bleak = "a cool dude" | |
def hi_blake | |
puts "hi blake you are #{blake}" | |
end | |
def hi_bleak | |
puts "hi bleak you are #{Bleak}" | |
end |