This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
# | |
# | |
# https://beamnetworks.dev | |
# CREATED BY: beamnetworks.dev | |
# | |
# | |
# SCRIPT WILL LIVE BACKUP A VM WITH PASSED THROUGH DATA WHEN SCRIPT IS RAN | |
# | |
# |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
:foreach interface in=[/interface ethernet find] do={ | |
:local interfaceName [/interface ethernet get number=$interface name]; | |
:local interfaceDefaultName [/interface ethernet get number=$interface default-name]; | |
[/interface ethernet set number=$interface name=$interfaceDefaultName] | |
} |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env sh | |
SWITCH_NAME="switch0" | |
apk update | |
apk add openvswitch openvswitch-bash-completion bash bash-completion openvswitch-doc openvswitch-openrc vim tcpdump ruby ruby-rdoc git | |
sed -i -e "s@mouse\=a@mouse=r@g" /usr/share/vim/vim*/defaults.vim | |
grep "mouse=a" /usr/share/vim/vim*/defaults.vim | |
grep "auto ${SWITCH_NAME}" /etc/network/interfaces >/dev/null |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<?php | |
header('Content-Type: application/json'); | |
$data = json_decode(file_get_contents('php://input'), true); | |
// Extract date and time from the request | |
$date = $data['date']; // Assuming date is in 'Y-m-d' format (e.g., '2024-07-05') | |
$time = $data['time']; // Assuming time is in 'H:i:s' format (e.g., '15:30:00') |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
{ | |
:do { | |
:log info "STARTING BACKUP"; | |
:local customerId [system/identity/get name ]; | |
:local boardId; | |
:local boardSerial; | |
:do { |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
FROM ubuntu:22.04 | |
RUN apt-get update && \ | |
apt-get upgrade -y && \ | |
apt-get install -y ansible && \ | |
apt-get clean autoclean && \ | |
apt-get autoremove --yes && \ | |
rm -rf /var/lib/{apt,dpkg,cache,log}/ |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
services: | |
sftpgo: | |
image: "drakkan/sftpgo:latest" | |
restart: always | |
ports: | |
- 8080:8080 | |
- 443:443 | |
- 5007:5007 | |
- 2022:2022 | |
volumes: |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
cd "c:\Program Files\Microsoft Office\Office16" | |
cscript OSPP.VBS /inpkey:FXYTK-NJJ8C-GB6DW-3DYQT-6F7TH | |
cscript ospp.vbs /sethst:kms.nbk.ngtech.co.il | |
cscript ospp.vbs /act | |
cscript ospp.vbs /dstatusall |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
dism /online /set-edition:serverstandard /productkey:VDYBN-27WPP-V4HQT-9VMD4-VMK7H /accepteula |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
{ | |
:local nasMacAddress "AA:BB:CC:11:22:33"; | |
/interface | |
:foreach iface in=[find] do={ | |
:local interfaceName [get $iface name]; | |
/tool/wol interface=$interfaceName mac=$nasMacAddress; | |
} | |
} |