This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
# In order to use this script, you need a backup user: | |
# CREATE USER backup@localhost; | |
# GRANT SELECT, USAGE, PROCESS, RELOAD, CLIENT REPLICATION ON *.* TO backup@localhost; | |
require 'fileutils' | |
BACKUP_DIR = "/srv/mysql" | |
MYSQL = "/usr/bin/mysql" |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
% mysqladmin --help | |
mysqladmin Ver 9.1 Distrib 10.1.18-MariaDB, for Linux on x86_64 | |
Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others. | |
Administration program for the mysqld daemon. | |
Usage: mysqladmin [OPTIONS] command command.... | |
Default options are read from the following files in the given order: | |
/etc/my.cnf /etc/mysql/my.cnf ~/.my.cnf | |
The following groups are read: mysqladmin client client-server client-mariadb |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
GIT(1) Git Manual GIT(1) | |
NAME | |
git - the stupid content tracker | |
SYNOPSIS | |
git [--version] [--help] [-C <path>] [-c <name>=<value>] | |
[--exec-path[=<path>]] [--html-path] [--man-path] [--info-path] | |
[-p|--paginate|--no-pager] [--no-replace-objects] [--bare] | |
[--git-dir=<path>] [--work-tree=<path>] [--namespace=<name>] |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# dec/12/2016 16:45:48 by RouterOS 6.37.3 | |
# software id = RE4F-WKP7 | |
# | |
/interface ethernet | |
set [ find default-name=ether2 ] name=ether2-master | |
set [ find default-name=ether3 ] master-port=ether2-master | |
set [ find default-name=ether4 ] master-port=ether2-master | |
set [ find default-name=ether5 ] master-port=ether2-master | |
/ip neighbor discovery | |
set ether1 discover=no |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
require 'fiber' | |
require 'nio' | |
module Async | |
end | |
class Async::Await | |
def initialize(ios, reactor) |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
require 'async' | |
require 'lightio' | |
def run_async(count = 10000) | |
start = Time.now | |
Async::Reactor.run do |task| | |
tasks = count.times.map do |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
require 'async/io' | |
require 'async/http/server' | |
require 'async/dns' | |
def print_server | |
Async::Reactor.run do |task| | |
task.async do | |
http_endpoints = Async::IO::Endpoint.tcp('localhost', 8081, reuse_port: true) |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
0493b1a5afb2044a2bf3b1eb3d7268cbba9027a2d550660e78bbf04e361a26babbd906bf6c91044097d73b2e4927e1d1c532bdf11e6e17bf8866935351de3f9287 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
* { | |
-webkit-font-smoothing: antialiased; | |
} | |
atom-text-editor { | |
text-rendering: optimizeLegibility; | |
} | |
atom-text-editor.editor .syntax--comment { | |
font-style: normal !important; |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# This is used in production, but I've extracted everything here, so this particular code is untested, but should work. | |
gem 'async-http-faraday' | |
gem 'async-websocket' | |
gem 'slack-api' | |
require 'slack' | |
require 'async/http/url_endpoint' |