This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
require 'async' | |
require 'lightio' | |
def run_async(count = 10000) | |
start = Time.now | |
Async::Reactor.run do |task| | |
tasks = count.times.map do |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
require 'fiber' | |
require 'nio' | |
module Async | |
end | |
class Async::Await | |
def initialize(ios, reactor) |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# dec/12/2016 16:45:48 by RouterOS 6.37.3 | |
# software id = RE4F-WKP7 | |
# | |
/interface ethernet | |
set [ find default-name=ether2 ] name=ether2-master | |
set [ find default-name=ether3 ] master-port=ether2-master | |
set [ find default-name=ether4 ] master-port=ether2-master | |
set [ find default-name=ether5 ] master-port=ether2-master | |
/ip neighbor discovery | |
set ether1 discover=no |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
GIT(1) Git Manual GIT(1) | |
NAME | |
git - the stupid content tracker | |
SYNOPSIS | |
git [--version] [--help] [-C <path>] [-c <name>=<value>] | |
[--exec-path[=<path>]] [--html-path] [--man-path] [--info-path] | |
[-p|--paginate|--no-pager] [--no-replace-objects] [--bare] | |
[--git-dir=<path>] [--work-tree=<path>] [--namespace=<name>] |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
% mysqladmin --help | |
mysqladmin Ver 9.1 Distrib 10.1.18-MariaDB, for Linux on x86_64 | |
Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others. | |
Administration program for the mysqld daemon. | |
Usage: mysqladmin [OPTIONS] command command.... | |
Default options are read from the following files in the given order: | |
/etc/my.cnf /etc/mysql/my.cnf ~/.my.cnf | |
The following groups are read: mysqladmin client client-server client-mariadb |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
# In order to use this script, you need a backup user: | |
# CREATE USER backup@localhost; | |
# GRANT SELECT, USAGE, PROCESS, RELOAD, CLIENT REPLICATION ON *.* TO backup@localhost; | |
require 'fileutils' | |
BACKUP_DIR = "/srv/mysql" | |
MYSQL = "/usr/bin/mysql" |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
void Renderer::generate_mipmaps(vk::CommandBuffer commands, DeviceImage image) { | |
size_t levels = image.info.mipLevels(); | |
assert(levels > 0); | |
vk::Extent3D extent = image.info.extent(); | |
vk::Offset3D upper (extent.width(), extent.height(), extent.depth()); | |
auto prepare_write = vk::ImageMemoryBarrier() | |
.dstAccessMask(vk::AccessFlagBits::eTransferWrite) |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/* | |
* Your Stylesheet | |
* | |
* This stylesheet is loaded when Atom starts up and is reloaded automatically | |
* when it is changed. | |
* | |
* If you are unfamiliar with LESS, you can read more about it here: | |
* http://www.lesscss.org | |
*/ |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
diff --git a/src/libscotch/Makefile b/src/libscotch/Makefile | |
index 073ac01..64abd50 100644 | |
--- a/src/libscotch/Makefile | |
+++ b/src/libscotch/Makefile | |
@@ -2963,7 +2963,7 @@ ptscotchf.h : ptdummysizes$(EXE) \ | |
./ptdummysizes$(EXE) library_pt_f.h ptscotchf.h | |
libscotch$(LIB) : $(LIBSCOTCHDEPS) | |
- $(AR) $(ARFLAGS) $(@) $(?) | |
+ $(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS) |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env ruby | |
begin | |
require 'bundler/inline' | |
rescue LoadError => e | |
$stderr.puts 'Bundler version 1.10 or later is required. Please update your Bundler' | |
raise e | |
end | |
gemfile(true) do |