Note: Some of these keymapping are specific to IdeaVim plugin. If you don't use IdeaVim (what' wrong with you :)), I've tried to point out where they differ, but I could have missed a few
Ctrl-P
- Popup parameter documentation for method calls
Note: Some of these keymapping are specific to IdeaVim plugin. If you don't use IdeaVim (what' wrong with you :)), I've tried to point out where they differ, but I could have missed a few
Ctrl-P
- Popup parameter documentation for method callsSo, how do i...
Once in a while, you may need to cleanup resources (containers, volumes, images, networks) ...
// see: https://github.com/chadoe/docker-cleanup-volumes
$ docker volume rm $(docker volume ls -qf dangling=true)
$ docker volume ls -qf dangling=true | xargs -r docker volume rm
If you are like me you find yourself cloning a repo, making some proposed changes and then deciding to later contributing back using the GitHub Flow convention. Below is a set of instructions I've developed for myself on how to deal with this scenario and an explanation of why it matters based on jagregory's gist.
To follow GitHub flow you should really have created a fork initially as a public representation of the forked repository and the clone that instead. My understanding is that the typical setup would have your local repository pointing to your fork as origin and the original forked repository as upstream so that you can use these keywords in other git commands.
Clone some repo (you've probably already done this step)
git clone [email protected]
oc annotate route <route_name> --overwrite haproxy.router.openshift.io/timeout=10s
oc patch dc|rc <dc_name> -p "spec:
template:
Prereq:
apt-get install zsh
apt-get install git-core
Getting zsh to work in ubuntu is weird, since sh
does not understand the source
command. So, you do this to install zsh
wget https://github.com/robbyrussell/oh-my-zsh/raw/master/tools/install.sh -O - | zsh
As configured in my dotfiles.
start new:
tmux
start new with session name:
#!/bin/sh | |
# | |
# Setup a work space called `work` with two windows | |
# first window has 3 panes. | |
# The first pane set at 65%, split horizontally, set to api root and running vim | |
# pane 2 is split at 25% and running redis-server | |
# pane 3 is set to api root and bash prompt. | |
# note: `api` aliased to `cd ~/path/to/work` | |
# | |
session="work" |
# jan/29/2018 22: 4:17 by RouterOS 6.41 | |
# | |
/interface list | |
add name=public comment="public network" | |
add name=local comment="local network" | |
add name=guest comment="guest network" | |
# Change the interfaces below to your own | |
/interface list member | |
add list=public interface=ether1 |
#!/usr/bin/env bash | |
destDir="../Takeout-merge" | |
mkdir -p $destDir | |
# Merges the different unzipped Takeout folders into one | |
for p in $(seq -f "%03g" 1 ${1:-1}); do | |
if [ -f $p/DONE ]; then | |
echo "Skipping $p/Takeout ... " |