sudo apt update
- Pull image from DockerHub:
docker pull [imageID] - Run image in detached mode along with a command:
docker run -d [imageID] [command] - Attatch a running container:
docker attatch [containerID] - Show Running Containers:
docker ps - Show All Containers:
docker ps -a - Kill running container:
docker stop [ContainerID/Name] - Remove container:
docker rm [ContainerID/Name]
A fully functional, secure ELK stack setup (Elasticsearch, Logstash, Kibana, APM-Server) for local development.
- Prerequisites (Linux Host) If running on Linux, increase the virtual memory map count, otherwise, Elasticsearch will fail to boot:
- Optional
sudo sysctl -w vm.max_map_count=262144
- Logstash Pipeline (logstash/pipeline/logstash.conf)