A fully functional, secure ELK stack setup (Elasticsearch, Logstash, Kibana, APM-Server) for local development.
- Prerequisites (Linux Host) If running on Linux, increase the virtual memory map count, otherwise, Elasticsearch will fail to boot:
- Optional
sudo sysctl -w vm.max_map_count=262144
- Logstash Pipeline (logstash/pipeline/logstash.conf)