Skip to content

Instantly share code, notes, and snippets.

View kurnias's full-sized avatar
💭
I may be slow to respond.

Sindhu Kurnia kurnias

💭
I may be slow to respond.
View GitHub Profile
@kurnias
kurnias / OpenWithSublimeText3.bat
Created September 10, 2016 23:35 — forked from roundand/OpenWithSublimeText3.bat
Open folders and files with Sublime Text 3 from windows explorer context menu (tested in Windows 7)
@echo off
SET st3Path=C:\Program Files\Sublime Text 3\sublime_text.exe
rem add it for all file types
@reg add "HKEY_CLASSES_ROOT\*\shell\Open with Sublime Text 3" /t REG_SZ /v "" /d "Open with Sublime Text 3" /f
@reg add "HKEY_CLASSES_ROOT\*\shell\Open with Sublime Text 3" /t REG_EXPAND_SZ /v "Icon" /d "%st3Path%,0" /f
@reg add "HKEY_CLASSES_ROOT\*\shell\Open with Sublime Text 3\command" /t REG_SZ /v "" /d "%st3Path% \"%%1\"" /f
rem add it for folders
@reg add "HKEY_CLASSES_ROOT\Folder\shell\Open with Sublime Text 3" /t REG_SZ /v "" /d "Open with Sublime Text 3" /f
@kurnias
kurnias / stealth.txt
Created October 19, 2016 00:58
Stealth Setting Mikrotik
/ ip firewall filter
add chain=input protocol=tcp dst-port=0-1055 action=drop comment="GRC Shield Up" disabled=no
add chain=input protocol=icmp action=drop comment="no ping" disabled=no
# Mikrotik configuration backup scripts
# Author: Sindhu Kurnia
# https://gist.github.com/kurnias/5732c326396c976d192c19e0f8c4aafd
#
# Script configuration please adjust this!
:local scriptName "cfgBackup"
:local email "[email protected]"
# months array
:local months ("jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec");
@kurnias
kurnias / logMonitor.rsc
Last active October 7, 2023 14:52
logMonitor scheduler script for Mikrotik
# BEGIN SETUP
:local scheduleName "logMonitor"
:local emailAddress "youremail"
:local startBuf [:toarray [/log find message~"Error" || message~"lost IP address" || message~"link down" || message~"link up" || message~"proto TCP" || message~"DC:9F:DB:56:F2:E6"]]
:local removeThese {"telnet";"whatever string you want"}
# END SETUP
# warn if schedule does not exist
:if ([:len [/system scheduler find name="$scheduleName"]] = 0) do={
/log warning "[LOGMON] ERROR: Schedule does not exist. Create schedule and edit script to match name"
Start server
$ sudo service mysql start
Go to sock folder
$ cd /var/run
Back up the sock
$ sudo cp -rp ./mysqld ./mysqld.bak
Stop server
Cara root Huawei HG680P
1. Masuk ke menu Settings –> Pengaturan tambahan. Cek apakah di bagian paling bawah ada menu Pengaturan Tambahan. Jika tidak ada, berarti Opsi Pengembang (Developer Mode) belum aktif, Aktifkan dengan cara: Klik Setting –> Informasi –> Informasi versi, tekan 5 kali hingga muncul tulisan “Developer mode enable“.
2. Kembali ke Pengaturan tambahan, di bagian paling bawah akan bertambah menu PENGATURAN TAMBAHAN. Klik meu tersebut — > More Settings –Opsi Pengembang — Aktifkan Debugging USB.
3. Download ADB versi ini. Ekstrak.
4. Download SuperSU.zip. Ekstrak lalu copy ke Flashdisk. Sebenarnya kita hanya butuh2 file, su (tanpa extensi) dan Superuser.apk.
5. Buka ADB pake command prompt, jalankan perintah:
@kurnias
kurnias / Instructions.sh
Created January 13, 2020 14:43 — forked from GhazanfarMir/Instructions.sh
Install PHP7.2 NGINX and PHP7.2-FPM on Ubuntu 16.04
########## Install NGINX ##############
# Install software-properties-common package to give us add-apt-repository package
sudo apt-get install -y software-properties-common
# Install latest nginx version from community maintained ppa
sudo add-apt-repository ppa:nginx/stable
# Update packages after adding ppa
@kurnias
kurnias / gist:c52ae6e0ba3125c710f63653be513d5e
Created August 20, 2020 14:40
Stripping TP-Link Firmware
$ dd if=wr1043nv1_en_3_13_13_up_boot\(130428\).bin of=wr1043nd_v1_correct.bin skip=257 bs=512