= General suggestions:
- In the beginning, keep the current method naming to avoid confusion (and to be able to search on method names), but mark in the comments what's probably to be renamed.
- In most cases it would be hard to simplify things without a deep refactor. I may forget why I did something one way or another, but each time I decide "this should not be needed", sooner or later it proves needed in a specific scenario... Tests would be of great help here.
= Core
- Class-level configuration:
- Netzke::Base.config and Netzke::GridPanel.config are decoupled.
- Example of usage: