This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
echo "install routeros on linux ubuntu 20" | |
wget https://download.mikrotik.com/routeros/6.44.6/chr-6.44.6.img.zip -O chr.img.zip && \ | |
gunzip -c chr.img.zip > chr.img && \ | |
mount -o loop,offset=512 chr.img /mnt && \ | |
ADDRESS=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \ | |
GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \ | |
echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1] | |
/ip route add gateway=$GATEWAY | |
/ip service disable telnet |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
ip tunnel add 6to4tun_IR mode sit remote 109.104.154.58 local 109.104.154.29 | |
ip -6 addr add 2001:470:1f10:e1f::1/64 dev 6to4tun_IR | |
ip link set 6to4tun_IR mtu 1480 | |
ip link set 6to4tun_IR up | |
ip -6 tunnel add GRE6Tun_IR mode ip6gre remote 2001:470:1f10:e1f::2 local 2001:470:1f10:e1f::1 | |
ip addr add 172.16.1.2/30 dev GRE6Tun_IR | |
ip link set GRE6Tun_IR mtu 1436 | |
ip link set GRE6Tun_IR up | |
ip route add default via 172.16.1.2 table 120 | |
ip rule add from 172.16.24.0/24 table 120 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
V2ray Tunnels | |
install v2ray | |
sudo apt install speedtest-cli | |
apt-get update -y && apt-get upgrade -y | |
sudo rm /var/lib/apt/lists/lock | |
sudo rm /var/cache/apt/archives/lock |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
اولین به این اموزش نیاز هست | |
https://help.mikrotik.com/docs/display/ROS/Container | |
فعال کردن کانتینر | |
/system/device-mode/update container=yes | |
ریبوت سخت افزاری | |
ساخت اینترفیس و نت | |
/interface/veth/add name=veth1 address=172.17.0.2/24 gateway=172.17.0.1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
fc00::1/8 | |
fc00::2/8 | |
2001:4860:4860::8888 | |
2001:4860:4860::8844 | |
#IRAN | |
ip tunnel add 6to4tun_IR mode sit remote 109.104.154.73 local 185.231.182.127 | |
ip -6 addr add fc00::1/8 dev 6to4tun_IR |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2001:4860:4860::8888 | |
2001:4860:4860::8844 | |
ifconfig sit0 up | |
ifconfig sit0 inet6 tunnel ::216.66.86.114 | |
ifconfig sit1 up | |
ifconfig sit1 inet6 add 2001:470:6c:1e::2/64 | |
route -A inet6 add ::/0 dev sit1 | |
Gre6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
if [ $(id -u) -eq 0 ]; then | |
read -p "Enter username : " username | |
egrep "^$username" /etc/passwd >/dev/null | |
if [ $? -eq 0 ]; then | |
echo -e "user $username exists!" | |
exit 1 | |
fi | |
read -p "Enter expire date ( y-m-d ) example 2023-06-10 : " date | |
read -p "Enter traffic (GB) : " traffic | |
read -p "Enter password : " password |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
0. install usermanager mikrotik IRAN | |
1. clock | |
/system clock | |
set time-zone-name=Asia/Tehran | |
/system clock manual | |
set time-zone=+03:30 | |
2. ntp | |
/system ntp client |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
yum install httpd php postgresql postgresql-server postgresql-python perl iptables-services tar zip unzip wget nano bzip2 install nano lsof net-tools -y | |
nano /etc/selinux/config | |
wget https://managedway.dl.sourceforge.net/project/ibsng/IBSng-A1.24.tar.bz2 | |
tar -xvjf IBSng-A1.24.tar.bz2 -C /usr/local | |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
اول باید یک ای پی ورژن 6 مجانی برای میکروتیک بگیرید | |
https://tunnelbroker.net | |
بعدش بیاید بر اساس سیستم عامل فایل اجرایی دانلود کنید باهاش اکانت وارپ بسازید | |
https://github.com/ViRb3/wgcf/releases/tag/v2.2.19 | |
باید 2 تا فیل بگیرید | |
[Interface] | |
PrivateKey = 4FbzCmwpi6eQ+hdwfI1PB7MERe7n9epNA0YJsGWbSHg= |
OlderNewer