This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
#cisco PAM | |
#comment privious installation | |
sed -e '/exclude=ocserv libev/ s/^#*/#/' -i /etc/yum.conf | |
IP=$(ip addr | grep 'inet' | grep -v inet6 | grep -vE '127\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}' | grep -oE '[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}' | head -1) | |
read -p "IP address: " -e -i $IP IP | |
if echo "$IP" | grep -qE '^(10\.|172\.1[6789]\.|172\.2[0-9]\.|172\.3[01]\.|192\.168)'; then | |
echo | |
echo "Enter Public IPv4 Address" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
#cisco | |
read -p "Port cisco : " PORT | |
IP=$(ip addr | grep 'inet' | grep -v inet6 | grep -vE '127\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}' | grep -oE '[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}' | head -1) | |
read -p "IP address: " -e -i $IP IP | |
# If $IP is a private IP address, the server must be behind NAT | |
if echo "$IP" | grep -qE '^(10\.|172\.1[6789]\.|172\.2[0-9]\.|172\.3[01]\.|192\.168)'; then | |
echo | |
echo "Enter Public IPv4 Address" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
#cisco | |
read -p "Port cisco : " PORT | |
IP=$(ip addr | grep 'inet' | grep -v inet6 | grep -vE '127\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}' | grep -oE '[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}' | head -1) | |
read -p "IP address: " -e -i $IP IP | |
# If $IP is a private IP address, the server must be behind NAT | |
if echo "$IP" | grep -qE '^(10\.|172\.1[6789]\.|172\.2[0-9]\.|172\.3[01]\.|192\.168)'; then | |
echo | |
echo "Enter Public IPv4 Address" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
https://www.softether-download.com/en.aspx | |
اگر زمان اتصال مشکل داشتید | |
اررور | |
"The time on the server and the client does not match" | |
sudo timedatectl set-timezone Asia/Tehran | |
بزنید تایم با ایران سینک بشه | |
softether / L2tp / SSTP / OPENVPN |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/certificate enable-ssl-certificate dns-name=domain.com |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/system scheduler | |
add interval=1d name="address lists IR1" on-event=\ | |
"/tool fetch url=http://www.iwik.org/ipcountry/mikrotik/IR\r\ | |
\n/import file-name=IR" policy=read,write,test start-time=startup | |
/tool fetch url=http://www.iwik.org/ipcountry/mikrotik/IR | |
/import file-name=IR |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
اول باید یک ای پی ورژن 6 مجانی برای میکروتیک بگیرید | |
https://tunnelbroker.net | |
بعدش بیاید بر اساس سیستم عامل فایل اجرایی دانلود کنید باهاش اکانت وارپ بسازید | |
https://github.com/ViRb3/wgcf/releases/tag/v2.2.19 | |
باید 2 تا فیل بگیرید | |
[Interface] | |
PrivateKey = 4FbzCmwpi6eQ+hdwfI1PB7MERe7n9epNA0YJsGWbSHg= |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
yum install httpd php postgresql postgresql-server postgresql-python perl iptables-services tar zip unzip wget nano bzip2 install nano lsof net-tools -y | |
nano /etc/selinux/config | |
wget https://managedway.dl.sourceforge.net/project/ibsng/IBSng-A1.24.tar.bz2 | |
tar -xvjf IBSng-A1.24.tar.bz2 -C /usr/local | |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
0. install usermanager mikrotik IRAN | |
1. clock | |
/system clock | |
set time-zone-name=Asia/Tehran | |
/system clock manual | |
set time-zone=+03:30 | |
2. ntp | |
/system ntp client |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
if [ $(id -u) -eq 0 ]; then | |
read -p "Enter username : " username | |
egrep "^$username" /etc/passwd >/dev/null | |
if [ $? -eq 0 ]; then | |
echo -e "user $username exists!" | |
exit 1 | |
fi | |
read -p "Enter expire date ( y-m-d ) example 2023-06-10 : " date | |
read -p "Enter traffic (GB) : " traffic | |
read -p "Enter password : " password |