This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
# directory structure: | |
# ~/s3sync has scripts | |
# ~/s3sync/s3backup is a folder for temp backup files | |
cd /home/tiernano | |
BUCKET=<BucketName> | |
BlogDBNAME=wordpress | |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
using System; | |
using System.Collections.Generic; | |
using System.Linq; | |
using System.Text; | |
using System.IO; | |
using System.Security.Cryptography; | |
using System.Diagnostics; | |
using System.Collections; | |
namespace Dedupe |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
using System; | |
using System.Web; | |
using System.Text; | |
using System.Net; | |
namespace CDNProxy | |
{ | |
public class CDNHandler : IHttpHandler | |
{ | |
/// <summary> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Import-Module bitstransfer | |
$url = "http://url.ie/fdvf" | |
$job = Start-BitsTransfer -source $url -Destination c:\downloads -Asynchronous | |
while (($job.JobState -eq 'Transferring') -or ($job.JobState -eq 'Connecting')){ | |
write-progress -Activity "Downloading" -status "percent complete" -PercentComplete (($job.bytesTransferred / $job.BytesTotal) * 100) | |
sleep 1 | |
} | |
if($job.JobState -eq 'Transferred') |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
$files = gci "path to your file location" | |
$handbrake = "C:\Program Files\HandBrake\HandBrakeCLI.exe" | |
foreach($file in $files) { | |
$newFileName = "path to where you want the files to be set to..." + [System.IO.Path]::GetFileNameWithoutExtension($file) + ".m4v" | |
& $handbrake -i $file.FullName -o $newFileName --preset "AppleTV 2" | |
if ($LastExitCode -ne 0) | |
{ | |
Write-Warning "Error converting $($file.FullName)" | |
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/ip firewall filter | |
add chain=forward action=drop src-address=srcaddress dst-address=!dstaddress |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/ip firewall address-list | |
add list=expressVPN address=77.92.85.58 | |
add list=expressVPN address=83.170.77.220 | |
add list=expressVPN address=109.169.27.39 | |
add list=expressVPN address=78.129.227.106 | |
/ip firewall filter | |
add action=drop chain=forward dst-address-list=!expressVPN src=address=192.168.0.123 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
cache_peer 127.0.0.1 parent 3300 0 no-query no-digest | |
never_direct allow all |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -clientopts -setvnclegacy -vnclegacy yes -clientopts -setvncpw -vncpw mypasswd -restart -agent -privs -all |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -deactivate -configure -access -off |
OlderNewer