Last active
April 13, 2023 05:37
-
-
Save ChrisG661/f2e9121cea57dbfb5ce7c950ed4c33dd to your computer and use it in GitHub Desktop.
MikroTik Zoom Hosts address list
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
## Made by ChrisG661, 2021 | |
## github.com/ChrisG661 | |
# Address list name | |
:local listname "zoom-hosts" | |
# Zoom IP range URLs | |
:local sourceUrl {"https://assets.zoom.us/docs/ipranges/Zoom.txt"; \ | |
"https://assets.zoom.us/docs/ipranges/ZoomMeetings.txt"; \ | |
"https://assets.zoom.us/docs/ipranges/ZoomCRC.txt"; \ | |
"https://assets.zoom.us/docs/ipranges/ZoomPhone.txt"} | |
# Import update script | |
:local updateList [:parse [/system script get UpdateAddressList source]] | |
# Remove existing addresses from the current Address list | |
/ip firewall address-list remove [/ip firewall address-list find list=$listname] | |
# Download each IP range files | |
:foreach url in=$sourceUrl do={ | |
/tool fetch mode=https url=$url | |
:delay 1 | |
} | |
# Load IP range files to address list | |
:local filenames {"Zoom.txt"; "ZoomMeetings.txt"; "ZoomCRC.txt"; "ZoomPhone.txt"} | |
:foreach file in=$filenames do={ | |
$updateList listname="zoom-hosts" filename=$file | |
:delay 1 | |
} | |
:log info "Zoom hosts address list updated" |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Requires MikroTik Address List Updater, make sure that both script is in system scripts and are named correctly. Copy both of the script to system scripts and make sure it is named the same as the file name (ZoomHosts and UpdateAddressList).
Run this to add the script to scheduler:
For usage with simple queue, simply run:
If used to bypass Zoom traffic, make sure to NOT set
max-limit
to unlimited as this will not work and packets will move to next queue.