Created
January 16, 2014 14:20
-
-
Save Jerry-Fix/8455738 to your computer and use it in GitHub Desktop.
nexus 752 step by step
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
1. 7004_A | |
开启特性 | |
feature vpc | |
feature lacp | |
no ip domain-lookup | |
建立 VRF 与 peer-keepalive,将建立的 peer-keepalive 成员端口加入到 VRF 中,与 7004 的路由表隔离 | |
interface mgmt0 | |
vrf member management | |
ip address 10.1.1.1/24 | |
vpc domain 1 | |
peer-keepalive destination 10.1.1.2 source 10.1.1.1 vrf management | |
创建 peer-link | |
interface Ethernet 4/47-48 | |
description n7k vpc peer-link | |
no shutdown | |
switchport | |
channel-group 1 mode active | |
interface port-channel 1 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc peer-link | |
#7004_A(config-if)# vpc peer-link | |
#Warning: | |
#Ensure that VPC peer-link member ports on both peers use identical VDC types (limit-resource module-type VDC config command). | |
#Please note that spanning tree port type is changed to "network" port type on vPC peer-link. | |
#This will enable spanning tree Bridge Assurance on vPC peer-link provided the STP Bridge Assurance | |
#(which is enabled by default) is not disabled. | |
创建 vPC | |
interface Ethernet 4/1-8 | |
no shutdown | |
switchport | |
channel-group 10 mode active | |
interface port-channel 10 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc 10 | |
2. 7004_B | |
开启特性 | |
feature vpc | |
feature lacp | |
no ip domain-lookup | |
建立 VRF 与 peer-keepalive,将建立的 peer-keepalive 成员端口加入到 VRF 中,与 7004 的路由表隔离 | |
interface mgmt0 | |
vrf member management | |
ip address 10.1.1.2/24 | |
vpc domain 1 | |
peer-keepalive destination 10.1.1.1 source 10.1.1.2 vrf management | |
创建 peer-link | |
interface Ethernet 4/47-48 | |
description n7k vpc peer-link | |
no shutdown | |
switchport | |
channel-group 1 mode active | |
interface port-channel 1 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc peer-link | |
创建 vPC | |
interface Ethernet 4/1-8 | |
no shutdown | |
switchport | |
channel-group 10 mode active | |
interface port-channel 10 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc 10 | |
3. 5548_A | |
开启特性 | |
feature vpc | |
feature lacp | |
feature fex | |
feature interface-vlan | |
建立 VRF 与 peer-keepalive,将建立的 peer-keepalive 成员端口加入到 VRF | |
vrf context management | |
interface mgmt0 | |
vrf member management | |
ip address 10.1.2.1/24 | |
vpc domain 1 | |
peer-keepalive destination 10.1.2.2 source 10.1.2.1 vrf management | |
创建 peer-link | |
interface Ethernet 1/31-32 | |
description n5k vpc peer-link | |
no shutdown | |
switchport | |
channel-group 1 mode active | |
interface port-channel 1 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc peer-link | |
创建 vPC | |
interface Ethernet 1/23-30 | |
no shutdown | |
switchport | |
channel-group 10 mode active | |
interface port-channel 10 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc 10 | |
4. 5548_B | |
开启特性 | |
feature vpc | |
feature lacp | |
feature fex | |
feature interface-vlan | |
建立 VRF 与 peer-keepalive,将建立的 peer-keepalive 成员端口加入到 VRF | |
vrf context management | |
interface mgmt0 | |
vrf member management | |
ip address 10.1.2.2/24 | |
vpc domain 1 | |
peer-keepalive destination 10.1.2.1 source 10.1.2.2 vrf management | |
创建 peer-link | |
interface Ethernet 1/31-32 | |
description n5k vpc peer-link | |
no shutdown | |
switchport | |
channel-group 1 mode active | |
interface port-channel 1 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc peer-link | |
创建 vPC | |
interface Ethernet 1/23-30 | |
no shutdown | |
switchport | |
channel-group 10 mode active | |
interface port-channel 10 | |
switchport mode trunk | |
switchport trunk allowed vlan all | |
vpc 10 | |
5. 5548 下挂 2248 | |
5.1 5548_A 配置 | |
feature fex | |
fex 101 | |
pinning max-links 1 | |
exit | |
fex 102 | |
pinning max-links 1 | |
exit | |
fex 103 | |
pinning max-links 1 | |
exit | |
fex 104 | |
pinning max-links 1 | |
exit | |
fex 105 | |
pinning max-links 1 | |
exit | |
fex 106 | |
pinning max-links 1 | |
exit | |
interface E1/1-4 | |
channel-group 101 mode on | |
interface port-channel 101 | |
switchport mode fex-fabric | |
fex associate 101 | |
exit | |
interface E1/5-8 | |
channel-group 102 mode on | |
interface port-channel 102 | |
switchport mode fex-fabric | |
fex associate 102 | |
exit | |
interface E1/9-12 | |
channel-group 103 mode on | |
interface port-channel 103 | |
switchport mode fex-fabric | |
fex associate 103 | |
exit | |
interface E1/13-16 | |
channel-group 104 mode on | |
interface port-channel 104 | |
switchport mode fex-fabric | |
fex associate 104 | |
exit | |
interface E1/17-20 | |
channel-group 105 mode on | |
interface port-channel 105 | |
switchport mode fex-fabric | |
fex associate 105 | |
exit | |
5.2 5548_B 配置 | |
feature fex | |
fex 101 | |
pinning max-links 1 | |
exit | |
fex 102 | |
pinning max-links 1 | |
exit | |
fex 103 | |
pinning max-links 1 | |
exit | |
fex 104 | |
pinning max-links 1 | |
exit | |
fex 105 | |
pinning max-links 1 | |
exit | |
fex 106 | |
pinning max-links 1 | |
exit | |
interface E1/1-4 | |
channel-group 101 mode on | |
interface port-channel 101 | |
switchport mode fex-fabric | |
fex associate 101 | |
exit | |
interface E1/5-8 | |
channel-group 102 mode on | |
interface port-channel 102 | |
switchport mode fex-fabric | |
fex associate 102 | |
exit | |
interface E1/9-12 | |
channel-group 103 mode on | |
interface port-channel 103 | |
switchport mode fex-fabric | |
fex associate 103 | |
exit | |
interface E1/13-16 | |
channel-group 104 mode on | |
interface port-channel 104 | |
switchport mode fex-fabric | |
fex associate 104 | |
exit | |
interface E1/17-20 | |
channel-group 106 mode on | |
interface port-channel 106 | |
switchport mode fex-fabric | |
fex associate 106 | |
exit |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment