This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/ip firewall filter | |
add action=drop chain=input dst-port=2828 \ | |
protocol=tcp src-address-list=!UpnpAllowed | |
add action=drop chain=input dst-port=1900 log=yes \ | |
protocol=udp src-address-list=!UpnpAllowed | |
/ip firewall address-list | |
add address=192.168.88.95 list=UpnpAllowed | |
add address=192.168.88.94 list=UpnpAllowed | |
add address=192.168.88.93 list=UpnpAllowed |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
INFO[2025-02-15T00:59:19.506001875Z] Starting up | |
WARN[2025-02-15T00:59:19.509286042Z] could not change group /data/data/com.termux/files/usr/var/run/docker.sock to docker: group docker not found | |
DEBU[2025-02-15T00:59:19.510265167Z] Listener created for HTTP on unix (/data/data/com.termux/files/usr/var/run/docker.sock) | |
INFO[2025-02-15T00:59:19.510393792Z] containerd not running, starting managed containerd | |
INFO[2025-02-15T00:59:19.513285959Z] started new containerd process address=/data/data/com.termux/files/usr/var/run/docker/containerd/containerd.sock module=libcontainerd pid=4608 | |
ERRO[0000] failure getting variant error="getCPUInfo for OS android: not implemented" | |
INFO[2025-02-15T00:59:19.588667509Z] starting containerd revision=3dce8eb055cbb6872793272b4f20ed16117344f8.m version=v1.6.21.m | |
INFO[2025-02-15T00:59:19.647495223Z] loading plugin "io.containerd.snapshotter.v1.aufs"... type=io.containerd.snapshotter.v1 | |
INFO[2025-02-15T00:59:19.65936022 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
set -e | |
# The working directory for all the following operations | |
export WORK_DIR=/home/workspaces | |
# Compiled file output directory | |
export OUTPUT_DIR=/dev/shm/ | |
# Default kernel configuration | |
export DEFCONFIG=raphael_user_defconfig |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import ( | |
"fmt" | |
"io" | |
"net/http" | |
"os" | |
) | |
func Download(url string, filepath string) error { | |
offset := int64(0) | |
info, err := os.Stat(filepath) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
// cli: frida --runtime v8 -l flutter_disable_ssl_validation.js -f com.my.target.package -H 192.168.0.123:6666 | |
function hook_ssl_verify_result(address) { | |
console.log('try to hook address:' + address) | |
Interceptor.attach(address, { | |
onEnter: function (args) { | |
console.log("Disabling SSL validation") | |
}, onLeave: function (retval) { | |
console.log("Retval: " + retval); | |
retval.replace(0x1); | |
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
FROM debian | |
RUN apt update && \ | |
apt install -y curl xz-utils make && \ | |
mkdir /toolchain && \ | |
curl -L -o /toolchain/arm.tar.xz "https://mirrors.tuna.tsinghua.edu.cn/armbian-releases/_toolchain/gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz" && \ | |
cd /toolchain && \ | |
xz -d arm.tar.xz && \ | |
tar -xvf /toolchain/arm.tar -C /toolchain && \ | |
rm /toolchain/arm.tar |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
myip(){ | |
IP_API_1="http://ip-api.com/json" | |
IP_API_2="https://ipapi.co/json/" | |
IP_API_RESULT_1=$(curl -s -X GET "${IP_API_1}" | jq -r .query) | |
if [ -z IP_API_RESULT_1 ] | |
then |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
version: "3" | |
services: | |
nginx: | |
image: nginx:1.21.6-alpine | |
environment: | |
- NGINX_ORDER_HOST=sample.com | |
- NGINX_ORDER_BACKEND=http://sample:8080 | |
volumes: | |
- "./nginx/templates:/etc/nginx/templates:ro" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/sh | |
apt-get remove docker docker-engine docker.io containerd runc | |
apt-get install -y \ | |
ca-certificates \ | |
curl \ | |
gnupg \ | |
lsb-release | |
curl -fsSL https://download.docker.com/linux/debian/gpg | gpg --dearmor -o /usr/share/keyrings/docker-archive-keyring.gpg | |
echo \ | |
"deb [arch=$(dpkg --print-architecture) signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/debian \ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
@echo off | |
pushd "%~dp0" | |
dir /b %SystemRoot%\servicing\Packages\*Hyper-V*.mum >hyper-v.txt | |
for /f %%i in ('findstr /i . hyper-v.txt 2^>nul') do dism /online /norestart /add-package:"%SystemRoot%\servicing\Packages\%%i" | |
del hyper-v.txt | |
Dism /online /enable-feature /featurename:Microsoft-Hyper-V-All /LimitAccess /ALL |
NewerOlder