Skip to content

Instantly share code, notes, and snippets.

Show Gist options
  • Save MartijnBraam/b325069aab012430cd8a8dd7f169529c to your computer and use it in GitHub Desktop.
Save MartijnBraam/b325069aab012430cd8a8dd7f169529c to your computer and use it in GitHub Desktop.
/interface vlan
add interface=ether1 name=vlan-uplink-internet vlan-id=6
/ppp profile
set 0 change-tcp-mss=yes name=default only-one=default use-compression=default use-encryption=default use-mlps=default use-vj-compression=default
/interface pppoe-client
add add-default-route=yes allow=pap,mschap2 dial-on-demand=no disabled=no interface=vlan-uplink-internet keepalive-timeout=20 max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-internet password=kpn profile=default use-peer-dns=no user=XX-XX-XX-XX-XX-XX@direct-adsl
/ip firewall nat
add chain=srcnat action=masquerade out-interface=pppoe-internet
add chain=srcnat dst-address=10.142.64.0/18 out-interface=vlan-upstream-iptv action=masquerade
add chain=srcnat dst-address=213.75.112.0/21 out-interface=vlan-upstream-iptv action=masquerade
/ip address
add address=192.168.88.1/24 interface=bridge-local
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1 netmask=24 dns-server=8.8.8.8,1.1.1.1
/ip pool
add name=dhcp-pool ranges=192.168.88.2-192.168.88.254
/ip dhcp-server option
add code=60 name=option60-vendorclass value=IPTV_RG
add code=28 name=option28-broadcast value=192.168.88.255
/ip dhcp-server option sets
add name=IPTV options=option60-vendorclass,option28-broadcast
/ip dhcp-server
add name=dhcp-lan address-pool=dhcp-pool authoritative=yes interface=bridge-local enabled=yes dhcp-option-set=IPTV
/ip dhcp-client option
add code=60 name=option60-vendorclass value="IPTV_RG"
/ip dhcp client
add add-default-route=special-classless default-route-distance=254 dhcp-options=option60-vendorclass disabled=no interface=vlan-upstream-iptv use-peer-dns=no use-peer-ntp=no
/routing igmp-proxy interface
add alternative-subnets=10.142.64.0/18,213.75.112.0/21 interface=vlan-upstream-iptv upstream=yes
add interface=bridge-local
/interface bridge
set bridge-local igmp-snooping=yes
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment