Find the culprit that prevents ejection of Flash Drives or any other unit.
wevtutil qe System /q:"*[System[(EventID=225)]]" /c:5 /f:text /rd:true
linux
Cascadia Code PL
included with "Windows Terminal" app or download from githubCascadiaCodePL.ttf
nerdfonts.com
Install Windows Terminal: https://github.com/microsoft/terminal/releases
Install Git for Windows: https://git-scm.com/downloads
Install Cascadia Code PL
Font: https://github.com/microsoft/cascadia-code/releases
# Magic of Math in Language | |
# v2.0 by @RomelSan (August 20, 2020) | |
#Functions | |
def sum_digits(n): | |
# Sum numbers until it is 1 digit | |
if n > 0: | |
s = (n-1) // 9 | |
return n-9*s | |
return 0 |
# Incident Response: Windows Cheatsheet | |
# Commands for CMD / Powershell / GUI | |
# Check user accounts | |
lusrmgr.msc | |
# See the user accounts for the system and the type of account it is | |
net user | |
Get-LocalUser | |
# Check Administrators | |
net localgroup administrators |
# List privileged services that don't come with Windows 10 | |
# Exclusion List for Win10 built in | |
$exclusion = @('AppVClient', 'ClickToRunSvc', 'COMSysApp', 'diagnosticshub.standardcollector.service', | |
'msiserver', 'ose', 'perceptionsimulation', 'SecurityHealthService', 'Sense', | |
'SensorDataService', 'SgrmBroker', 'Spooler', 'ssh-agent', 'TieringEngineService', | |
'TrustedInstaller', 'UevAgentService', 'vds', 'VSS', 'wbengine', 'WinDefend', 'wmiApSrv', | |
'WSearch', 'SamSs') | |
# Get Service List with LocalSystem and Startmode Auto and does not contain svchost.exe (Also exclude the ones from the list) |
# Minimum size of USB stick 6GB | |
# Set here the path of your ISO file | |
$iso = 'C:\Users\localuser\Downloads\en_win10.iso' | |
# Clean ! will clear any plugged-in USB stick!! | |
Get-Disk | Where BusType -eq 'USB' | | |
Clear-Disk -RemoveData -Confirm:$true -PassThru | |
# Convert GPT |
# Mikrotik Personal Queue Tree based on Priority for devices | |
# Mark in Mangle (Global Internet, Devices Download, Devices Upload) | |
/ip firewall mangle | |
add action=mark-connection chain=prerouting comment="Internet Download" in-interface=ether10-Internet new-connection-mark=Internet_conn passthrough=yes | |
add action=mark-packet chain=prerouting connection-mark=Internet_conn new-packet-mark=Internet passthrough=no | |
add action=mark-connection chain=forward comment="Main Camera Download" dst-address=192.168.0.10 new-connection-mark=Camera_Conn_FW packet-mark=Internet passthrough=yes | |
add action=mark-packet chain=forward connection-mark=Camera_Conn_FW new-packet-mark="Camera_Download" passthrough=no |
<NotepadPlus> | |
<UserLang name="RouterOS" ext="rsc" udlVersion="2.1"> | |
<Settings> | |
<Global caseIgnored="yes" allowFoldOfComments="no" foldCompact="no" forcePureLC="0" decimalSeparator="0" /> | |
<Prefix Keywords1="no" Keywords2="no" Keywords3="yes" Keywords4="no" Keywords5="no" Keywords6="no" Keywords7="no" Keywords8="no" /> | |
</Settings> | |
<KeywordLists> | |
<Keywords name="Comments">00# 01 02 03 04</Keywords> | |
<Keywords name="Numbers, prefix1"></Keywords> | |
<Keywords name="Numbers, prefix2"></Keywords> |