Skip to content

Instantly share code, notes, and snippets.

@Sixl-Daniel
Last active December 19, 2018 09:35
Show Gist options
  • Save Sixl-Daniel/2d63f2086bfb38fdd9b0518c4cec4e58 to your computer and use it in GitHub Desktop.
Save Sixl-Daniel/2d63f2086bfb38fdd9b0518c4cec4e58 to your computer and use it in GitHub Desktop.
Fran
Mask Slash Subnets and Range Available hosts
.128 /25 2sn à 128 126h
.129 /26 4sn à 64 62h
.224 /27 8sn à 32 30h
.240 /28 16sn à 16 14h
.248 /29 32sn à 8 6h
.252 /30 64sn à 4 2h
.254 /31 128sn à 2

0 - 15
16 - 31
32 - 47
48 - 63
64 - 79
80 - 95
96 - 111
112 - 127
128 - 143
144 - 159
160 - 175
176 - 191
192 - 207
208 - 223
224 - 239
240 - 255

Addressing Table

Building 1, Town Hall, CS Department (Router)
G0/0 192.168.1.126 255.255.255.224 (2001:DB8:ACAD:A::1/64)
G0/1 192.168.1.158 255.255.255.240 (2001:DB8:ACAD:B::1/64)
Link Local FE80::1

Second Floor Switch, Administration Switch, LAB 214-A Switch (Switch)
VLAN 1
192.168.1.157 / 255.255.255.240
Default Gateway 192.168.1.158

Host1, Reception Host, 124-1
192.168.1.97 / 255.255.255.224
Default Gateway 192.168.1.126 / FE80::1

Host2, Operator Host, 124-5
192.168.1.98 / 255.255.255.224
Default Gateway 192.168.1.126 / FE80::1

Host3, IT Host, 214-1
192.168.1.145 / 255.255.255.240
Default Gateway 192.168.1.158 / FE80::1

TFTP Server
192.168.1.146 / 255.255.255.240
Default Gateway 192.168.1.158 / FE80::1

1) Determine the IP Addressing Scheme

https://ccnav6.com/cidrvlsm-calculator-online

Subnet Hosts Network Begin End Mask Assignment
1 30 192.168.1.0 192.168.1.1 192.168.1.30 255.255.255.224
2 30 192.168.1.32 192.168.1.33 192.168.1.62 255.255.255.224
3 30 192.168.1.64 192.168.1.65 192.168.1.94 255.255.255.224
4 30 192.168.1.96 192.168.1.97 192.168.1.126 255.255.255.224 First Floor LAN Subnet, IT Department LAN Subnet
5 14 192.168.1.128 192.168.1.129 192.168.1.142 255.255.255.240
6 14 192.168.1.144 192.168.1.145 192.168.1.158 255.255.255.240 Second Floor LAN Subnet, Administration LAN Subnet

Configuring

Host 1 (GUI Desktop - IP Configuration : Static)

IPv4 192.168.1.97 255.255.255.224
GWv4 192.168.1.126
IPv6 2001:DB8:ACAD:A::FF / 64
GWv6 FE80::1

Host 2 (GUI Desktop - IP Configuration : Static)

IPv4 192.168.1.98 255.255.255.224
GWv4 192.168.1.126
IPv6 2001:DB8:ACAD:A::15 / 64
GWv6 FE80::1

Host 3 (GUI Desktop - IP Configuration : Static)

IPv4 192.168.1.145 255.255.255.240
GWv4 192.168.1.158
IPv6 2001:DB8:ACAD:B::FF / 64
GWv6 FE80::1

TFTP Server (GUI Desktop - IP Configuration : Interface FastEthernet0 : Static)

IPv4 192.168.1.146 255.255.255.240
GWv4 192.168.1.158
IPv6 2001:DB8:ACAD:B::15 / 64
GWv6 FE80::1

Switch

Use line console to connect Host 3 and Second Floor Switch.
On Host 3, go to "Desktop Tab" --> choice "Terminal"

enable
conf terminal
enable secret class12345
service password-encryption
banner motd $Second Floor Switch$
no ip domain-lookup

line console 0
password cisco12345
login
logging synchronous
exec-timeout 60
exit

line vty 0 15
password cisco12345
login
logging synchronous
exec-timeout 60
exit

interface vlan 1
ip address 192.168.1.157 255.255.255.240
no shutdown

ip default-gateway 192.168.1.158
exit
write

Router

Use line console to connect Host 1 and Building 1 Router.
On Host 1, go to “Desktop Tab” –> choice “Terminal”

en
conf terminal
hostname Middle
enable secret class12345
service password-encryption
banner motd $This is Router$
security passwords min-length 10
login block-for 120 attempts 2 within 30
no ip domain-lookup
ip domain-name ccnav6.com
crypto key generate rsa
1024

line console 0
password cisco12345
login
logging synchronous
exec-timeout 60
exit

line vty 0 4
password cisco12345
transport input ssh
login local
logging synchronous
exec-timeout 60
exit

line aux 0
password cisco12345
login
logging synchronous
exec-timeout 60
exit

ip ssh version 2
ip ssh time-out 120
username netadmin privilege 15 secret Cisco_CCNA5

interface g0/0
ip address 192.168.1.126 255.255.255.224
description First Floor LAN
ipv6 address 2001:DB8:ACAD:A::1/64
ipv6 address fe80::1 link-local
no shutdown
exit

interface g0/1
ip address 192.168.1.158 255.255.255.240
description Second Floor LAN
ipv6 address 2001:DB8:ACAD:B::1/64
ipv6 address fe80::1 link-local
no shutdown
exit
ipv6 unicast-routing
exit
write

copy running-config tftp: 
192.168.1.146
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment