Skip to content

Instantly share code, notes, and snippets.

@aduzsardi
Created July 25, 2017 07:48
Show Gist options
  • Save aduzsardi/bf5da6ba6f5258b7d9063a8e066216d4 to your computer and use it in GitHub Desktop.
Save aduzsardi/bf5da6ba6f5258b7d9063a8e066216d4 to your computer and use it in GitHub Desktop.
configure LCAP bonding Linux - Cisco IOS
# ---- START Cisco IOS ----
interface Port-channel2
description LACP Channel for mk2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2
switchport mode trunk
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/23
description mk2 eth0
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/0/24
description mk2 eth1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
# ---- END Cisco IOS -----
# --- START Debian Linux ---
# /etc/modules: kernel modules to load at boot time.
bonding
# /etc/network/interfaces
auto eth0
iface eth0 inet manual
bond-master bond0
auto eth1
iface eth1 inet manual
bond-master bond0
auto bond0
iface bond0 inet static
address 10.11.3.3
gateway 10.11.3.254
netmask 255.255.255.0
bond-mode 4
bond-miimon 100
bond-lacp-rate 1
bond-slaves none
# Check status
cat /proc/net/bonding/bond0 - Linux
show interfaces Port-channel 2 - Cisco IOS
# Docs
# https://www.kernel.org/doc/Documentation/networking/bonding.txt
# https://help.ubuntu.com/community/UbuntuBonding
# https://backdrift.org/lacp-configure-network-bonding-linux
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment