Skip to content

Instantly share code, notes, and snippets.

@alexanderfefelov
Created August 29, 2014 06:41
Show Gist options
  • Save alexanderfefelov/df3c562ea2e42438c940 to your computer and use it in GitHub Desktop.
Save alexanderfefelov/df3c562ea2e42438c940 to your computer and use it in GitHub Desktop.
How to configure a Cisco Catalyst switch to act as a DHCP relay agent with option 82
  +-------------+
  |             |
  | DHCP server |
  |             |
  +-------------+
          | 192.168.1.34
          |
          |
   VLAN 1 | 192.168.1.12
  +------[1]----+
  |             | Cisco Catalyst 2960 IOS 12.2(55)SE5
  | DHCP relay  | 00:1A:A1:D3:91:00
  |             |
  +-----[24]----+
 VLAN 996 | 192.168.78.5
          |
          |
          |
  +-------------+
  |             |
  | DHCP client |
  |             |
  +-------------+
  
interface Vlan1
    ip address 192.168.1.12 255.255.255.0
vlan 996
interface Vlan996
    ip address 192.168.78.5 255.255.255.0
    ip helper-address 192.168.1.34
interface FastEthernet0/24
    switchport mode access
    switchport access vlan 996
service dhcp
ip dhcp snooping
ip dhcp snooping vlan 996
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment