This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
LANG="en_US.UTF-8" | |
LC_CTYPE="es_AR.UTF-8" | |
LC_NUMERIC="es_AR.UTF-8" | |
LC_TIME="es_AR.UTF-8" | |
LC_COLLATE="es_AR.UTF-8" | |
LC_MONETARY="es_AR.UTF-8" | |
LC_MESSAGES="en_US.UTF-8" | |
LC_PAPER="es_AR.UTF-8" | |
LC_NAME="es_AR.UTF-8" | |
LC_ADDRESS="es_AR.UTF-8" |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import json | |
repetidos = [1, 2, 3, "1", "2", "3", 3, 4, 5] | |
r = [1, "5", 2, "3"] | |
d_str = '{"valor":125.3,"codigo":123}' | |
def _elements_to_int(elements): | |
return [int(e) for e in elements] |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# coding: utf-8 | |
import requests | |
from base64 import b64encode | |
from datetime import datetime | |
gsm = ("@£$¥èéùìòÇ\nØø\rÅåΔ_ΦΓΛΩΠΨΣΘΞ\x1bÆæßÉ !\"#¤%&'()*+,-./0123456789:;<=>?" | |
"¡ABCDEFGHIJKLMNOPQRSTUVWXYZÄÖÑÜ`¿abcdefghijklmnopqrstuvwxyzäöñüà") | |
ext = ("````````````````````^```````````````````{}`````\\````````````[~]`" | |
"|````````````````````````````````````€``````````````````````````") |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# may/28/2020 21:53:06 by RouterOS 6.46.6 | |
# software id = ISSB-RQLV | |
# | |
# model = RB750Gr3 | |
/interface bridge | |
add comment="LAN Switch" name=bridge | |
/interface ethernet | |
set [ find default-name=ether1 ] comment="ISP Claro" name=wan1 | |
set [ find default-name=ether2 ] comment="ISP Movistar" name=wan2 | |
/interface list |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
17:08:03 interface,info wan2 link up (speed 1G, full duplex) | |
17:08:03 dhcp,debug,state dhcp-client on wan2 entering <selecting...> state | |
17:08:03 dhcp,debug,packet dhcp-client on wan2 sending discover with id 2763417222 to 255.255.255.255 | |
17:08:03 dhcp,debug,packet flags = broadcast | |
17:08:03 dhcp,debug,packet ciaddr = 0.0.0.0 | |
17:08:03 dhcp,debug,packet chaddr = 74:4D:28:--:--:-- | |
17:08:03 dhcp,debug,packet Msg-Type = discover | |
17:08:03 dhcp,debug,packet Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server,CAPWAP-Server,Vendor-Specific | |
17:08:03 dhcp,debug,packet Host-Name = "hex" | |
17:08:03 dhcp,debug,packet Client-Id = 01-74-4D-28-__-__-__ |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
16:54:26 dhcp,debug,state dhcp-client on wan2 entering <stopped> state | |
16:54:26 dhcp,info dhcp-client on wan2 lost IP address 192.168.1.10 - lease stopped locally | |
16:54:26 dhcp,debug,packet dhcp-client on wan2 sending release with id 201958310 to 192.168.1.1 | |
16:54:26 dhcp,debug,packet ciaddr = 192.168.1.10 | |
16:54:26 dhcp,debug,packet chaddr = 74:4D:28:--:--:-- | |
16:54:26 dhcp,debug,packet Msg-Type = release | |
16:54:26 dhcp,debug,packet Server-Id = 192.168.1.1 | |
16:54:26 dhcp,debug,packet Client-Id = 01-74-4D-28-__-__-__ | |
16:54:26 dhcp,debug,state dhcp-client on wan2 entering <selecting...> state | |
16:54:26 system,info netwatch host modified |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
$altura = 11; | |
$c = 90; | |
difference() { | |
difference() { | |
cube([354, 253, $altura]); | |
translate([5, 5, 3]) | |
cube([344, 223, 8]); | |
}; | |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/sh | |
iface='pppoe0' | |
afraid='-- GET IT AT https://freedns.afraid.org/dynamic/ --' | |
ip=$(/sbin/ip -o -4 addr list $iface | awk '{print $4}' | cut -d/ -f1) | |
url="https://freedns.afraid.org/dynamic/update.php?$afraid&address=$ip" | |
curl "$url" |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
[core] | |
editor = vim | |
[alias] | |
hist = log --pretty=format:\"%C(yellow)%h%Creset %C(cyan)%ad%Creset %s [%Cgreen%an%Creset]\" --graph --date=short |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/sh | |
CURRENT_IP=/tmp/current_ip | |
ASSIGNED_IP=/tmp/assigned_ip | |
test -e $ASSIGNED_IP || touch $ASSIGNED_IP | |
curl http://ip.init.gdn:8989/txt -s -o $CURRENT_IP | |
cmp $CURRENT_IP $ASSIGNED_IP -s || (curl https://freedns.afraid.org/dynamic/update.php?__HASH_HERE__ && cp $CURRENT_IP $ASSIGNED_IP && echo "IP updated $(cat $CURRENT_IP)") |
NewerOlder