So let's work together
Instead of having one controller object that does everything, I've been trying to split things out into various task-focused. This means I have to come up with names for these objects, such as "CoverAnimationDriver", etc. Naming things is hard, so I want your help. Aside from domain-specific bag-of-properties model objects, what nouns have you used in class names? In my experience, these are usually used as a suffix on the class name.
Here's what I've come up with so far:
- View
- Controller
- Manager
- Data Source
- Driver
- Strategy
- Processor
- Provider
I'd love more ideas. Comment below.
Motivating example: What would you call an object that attempts to fill in missing or lost data in a Foo object? FooRepairer? FooRepairShop? FooCompleter?