This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
sudo dscacheutil -flushcache; | |
sudo killall -HUP mDNSResponder; | |
sleep 2; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#Local dev env and testing | |
cfn-templates/parameters.local | |
.env | |
.kitchen/ | |
.kitchen.local.yml | |
.vagrant | |
.venv | |
yarn_npm_package/*/node_modules | |
env/ | |
venv/ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
# Full script for fixing homebrew update error | |
# Reset | |
sudo rm -rf /Library/Developer/CommandLineTools | |
xcode-select --install | |
# Reset homebrew-cask | |
brew untap homebrew/homebrew-cask - -force | |
brew reinstall cask |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
sudo dnf remove -y strongswan NetworkManager-strongswan NetworkManager-strongswan-gnome strongswan-libipsec | |
sudo dnf install -y libreswan NetworkManager-libreswan NetworkManager-libreswan-gnome ldns nss-tools firewall-config | |
echo "Changing ipsec.conf" | |
sudo sed -i 's/# dnssec-enable=no/dnssec-enable=no/g' /etc/ipsec.conf | |
sudo sed -i 's/#DNSSEC=allow-downgrade/DNSSEC=false/g' /etc/systemd/resolved.conf | |
echo "Configuring Firewall" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Certificate creation for users | |
/certificate add [email protected] [email protected] [email protected] subject-alt-name=email:[email protected] | |
/certificate sign [email protected] ca=CA.yourdomain.com | |
/certificate export-certificate [email protected] type=pkcs12 export-passphrase=YOURPASSPHRASE | |
/ip ipsec identity add auth-method=digital-signature certificate=vpn.yourdomain.com [email protected] generate-policy=port-strict match-by=certificate mode-config="modeconf vpn.yourdomain.com" peer="peer 1.1.1.1" policy-template-group="group vpn.yourdomain.com" remote-id=user-fqdn:[email protected] |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Mikrotik RouterOs IKEv2/IPSec VPN Full configuration | |
# RouterOS v6.45+ | |
/system identity | |
set name=mikrotik_aws_vpn_ikev2 | |
/system clock | |
set time-zone-name=Europe/Dublin | |
/system ntp client |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Mikrotik RouterOs PPTP VPN Full configuration | |
# | |
/interface bridge | |
add fast-forward=no name=bridge | |
/interface ethernet | |
set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full | |
/interface bridge port |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Mikrotik RouterOs L2TP/IPSec VPN Full configuration | |
# | |
/interface bridge | |
add fast-forward=no name=bridge | |
/interface ethernet | |
set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full | |
/interface bridge port |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
sudo yum -y install gcc kernel kernel-devel tbb tbb-devel | |
echo "Download and install AWS NVIDIA GPU Drivers"; | |
curl -o NVIDIA.run https://s3.amazonaws.com/ec2-linux-nvidia-drivers/grid-10.0/NVIDIA-Linux-x86_64-440.43-grid.run | |
sudo /bin/sh ./NVIDIA.run |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<?php | |
require_once '../private/config.php'; | |
require_once $CONF->private . 'Project.php'; | |
require_once $CONF->lib . 'aws/aws-autoloader.php'; | |
define('AWS_KEY', $CONF->AWS_KEY); | |
define('AWS_SECRET_KEY', $CONF->AWS_SECRET_KEY); | |
define('HOST', 'https://s3.amazonaws.com/'); | |
use Aws\S3\S3Client; |
NewerOlder