Yes largo, that's the name of this
The idea behind this is that in any case that you might find yourself having more than 40 - 80 lines of code in a single file you should split that file into smaller (therefore more readable) files.
Follow the next convention
[folderName]
- index.[ext] (entry file)
- folderName.[name].[ext] (single file related to folder)
[utils] (...more on this later)
[components] (is a folder for pieces of logic, name this according to your coding context, e.g. frontend vs backend codebases)
-
index.[ext] (entry file)
-
components.[name].[ext] (single file)
[utils] (is a folder that handles small logic i.e. utiliratian files or functions)
-
index.[ext] (entry file)
-
utils.[name].[ext] (single util file)