This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
# https://bugs.launchpad.net/oem-priority/+bug/1939565 | |
cd /var/lib/shim-signed/mok/ | |
openssl genrsa -out MOK.priv 2048 | |
openssl req -new -x509 -sha256 -subj '/CN=Example-key' -key MOK.priv -out MOK.pem -days 1231111 | |
openssl x509 -in MOK.pem -inform PEM -out MOK.der -outform DER -days 1231111 | |
mokutil --import MOK.der | |
cd - |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
config interface 'wan' | |
option ifname 'eth1' | |
option proto 'pppoe' | |
option ipv6 '1' | |
option peerdns '0' | |
option dns '8.8.8.8' | |
option dns '8.8.4.4' | |
option username '[email protected]' | |
option password 'password' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
... | |
config zone | |
option name 'wan' | |
option input 'REJECT' | |
option output 'ACCEPT' | |
option forward 'REJECT' | |
option masq '1' | |
option mtu_fix '1' | |
option network 'wan wan6' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
description "openvpn client service instance" | |
start on runlevel [2345] | |
stop on runlevel [!2345] | |
respawn | |
respawn limit 10 5 | |
expect fork |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
function FindProxyForURL(url, host) | |
{ | |
return "SOCKS5 localhost:8080; SOCKS5 localhost:8081; SOCKS5 localhost:8082"; | |
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/python | |
__version__="0.0.1" | |
__author__="david" | |
__email__="[email protected]" | |
import argparse | |
import csv | |
import json | |
from multiprocessing import Process | |
import netaddr |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
your user | other user | |
| | |
su otheruser | xauth -f ~/.Xauthority add :1 . `mcookie` | |
| export DISPLAY="1:0" | |
#get a copy of the cookie file | | |
#run up xephyr | | |
Xephyr :1 -auth OTHER_USERS_XAUTH -screen 1280x1024 | | |
| dbus-launch | |
| gnome-session |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import sys | |
import socket | |
def return_red(string): | |
return "\033[1;31m" + string + "\033[m" | |
console = open("/dev/console", "w") | |
while True: | |
f = open("/proc/kmsg", 'r') |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import time | |
import subprocess | |
def is_screen_locked(): | |
output = subprocess.Popen(["gnome-screensaver-command", "--query"], stdout=subprocess.PIPE).communicate()[0] | |
if "screensaver is inactive" in output: | |
return False | |
return True | |
def monitor_and_unlock(usb_id): |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#include <linux/module.h> | |
#include <linux/kernel.h> | |
#include <linux/fs.h> | |
#include <asm/uaccess.h> | |
#define DRIVER_AUTHOR "Dave B. <[email protected]>" | |
#define DRIVER_DESC "Rickroll ;)" | |
#define DEVICE_NAME "chardev" | |
MODULE_LICENSE("GPL"); |
NewerOlder