Skip to content

Instantly share code, notes, and snippets.

@darkarnium
Last active March 29, 2020 17:27
Show Gist options
  • Save darkarnium/4aa497d8195705ea75e3d13c836da2b7 to your computer and use it in GitHub Desktop.
Save darkarnium/4aa497d8195705ea75e3d13c836da2b7 to your computer and use it in GitHub Desktop.
LEDE PPPoE dialer for BT VDSL on QCA8337
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '6 4 3 2 1'
config switch_vlan
option device 'switch0'
option vlan '2'
option vid '1337'
option ports '5t 0'
config switch_vlan
option device 'switch0'
option vlan '3'
option vid '101'
option ports '5t 0'
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'wan'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option proto 'pppoe'
option delegate '0'
option username '[email protected]'
option password 'blank'
option ipv6 '0'
option mtu '1492'
option ifname 'eth0'
config interface 'lan'
option ipv6 '0'
option type 'bridge'
option ifname 'eth1'
option proto 'static'
option netmask '255.255.255.0'
option dns '192.168.15.1'
option delegate '0'
option ipaddr '192.168.15.1'
config interface 'xdslmgmt'
option ipv6 '0'
option proto 'static'
option ifname 'eth0.1337'
option ipaddr '172.31.254.2'
option netmask '255.255.255.252'
option delegate '0'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment