Skip to content

Instantly share code, notes, and snippets.

@dragonfire1119
Last active February 17, 2025 11:07
Show Gist options
  • Save dragonfire1119/f3acd42414abfff762d2dad5e50f7cc6 to your computer and use it in GitHub Desktop.
Save dragonfire1119/f3acd42414abfff762d2dad5e50f7cc6 to your computer and use it in GitHub Desktop.
Install OpenWRT on Proxmox

Blog Post

https://community.bigbeartechworld.com/t/setting-up-openwrt-on-a-virtual-machine-with-proxmox/257

Get url to image

https://images.linuxcontainers.org/images/openwrt/23.05/amd64/default/20231123_11:57/rootfs.tar.xz

Create the vm

pct create 202 /var/lib/vz/template/cache/OpenWRT.tar.xz --arch amd64 --hostname OpenWrt-21.02 --rootfs local-lvm:20 --memory 1024 --cores 2 --ostype unmanaged --unprivileged 1

Add the lan bridge

vim /etc/config/network
config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.*'
@rpratama123
Copy link

Hi, you might want to check the latest version of OpenWRT from here:
https://images.linuxcontainers.org/images/openwrt/23.05/amd64/default/

@dragonfire1119
Copy link
Author

Hi, you might want to check the latest version of OpenWRT from here: https://images.linuxcontainers.org/images/openwrt/23.05/amd64/default/

I updated it, and thank you for letting me know.

@rpratama123
Copy link

Anytime! This gist and your video on YouTube helped me on setting up OpenWRT container on my Proxmox server.
Small problem though, I can't manage to get DHCP work under unprivileged container. It has to do with ports under 1024 are essentially reserved only for privileged users.

@casquijo
Copy link

Thank you very much!

@suuhm
Copy link

suuhm commented Jan 6, 2024

Thanks for the script:
I've just updated it a little bit for easier noobie installing:

https://gist.github.com/suuhm/053f819b000bee4af922d66ff6c5d32e

@dragonfire1119
Copy link
Author

Thanks for the script: I've just updated it a little bit for easier noobie installing:

https://gist.github.com/suuhm/053f819b000bee4af922d66ff6c5d32e

Awesome. Would you be able to make a pull request to https://github.com/bigbeartechworld/big-bear-scripts?

@KageDev
Copy link

KageDev commented Nov 3, 2024

config above is weird, with it my container didn't have internet access.
here's my full config after fixes:

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth0'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.8.51'
        option device 'br-lan'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        option ipv6 '0'

config device
        option name 'eth1'

config device
        option name 'eth0'

@axelprod885
Copy link

axelprod885 commented Dec 5, 2024

my container doesn't have internet access. Please help!!
Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment