Created
June 18, 2013 08:34
-
-
Save dukelion/5803645 to your computer and use it in GitHub Desktop.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# No-IP automatic Dynamic DNS update | |
#--------------- Change Values in this section to match your setup ------------------ | |
# No-IP User account info | |
:local noipuser "login" | |
:local noippass "password" | |
# Set the hostname or label of network to be updated. | |
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names. | |
# To specify multiple hosts, separate them with commas. | |
:local noiphost "myhost.no-ip.org" | |
# Change to the name of interface that gets the dynamic IP address | |
:local inetinterface "wan-interface" | |
#------------------------------------------------------------------------------------ | |
# No more changes need | |
:global previousIP | |
:if ([/interface get $inetinterface value-name=running]) do={ | |
# Get the current IP on the interface | |
:local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address] | |
# Strip the net mask off the IP address | |
:for i from=( [:len $currentIP] - 1) to=0 do={ | |
:if ( [:pick $currentIP $i] = "/") do={ | |
:set currentIP [:pick $currentIP 0 $i] | |
} | |
} | |
:if ($currentIP != $previousIP) do={ | |
:log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed" | |
# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands. | |
:local url "http://dynupdate.no-ip.com/nic/update?myip=$currentIP" | |
:local noiphostarray | |
:set noiphostarray [:toarray $noiphost] | |
:foreach host in=$noiphostarray do={ | |
:log info "No-IP: Sending update for $host" | |
/tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt") | |
:log info "No-IP: Host $host updated on No-IP with IP $currentIP" | |
} | |
:set previousIP $currentIP | |
} else={ | |
:log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed" | |
} | |
} else={ | |
:log info "No-IP: $inetinterface is not currently running, so therefore will not update." | |
} |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment