Skip to content

Instantly share code, notes, and snippets.

@Vinaco00
Vinaco00 / archive-all-chatgpt-chats.js
Last active February 13, 2025 22:41 — forked from aomarks/archive-all-chatgpt-chats.js
Archive all ChatGPT chats browser script
// This script will iterate over all of your ChatGPT sessions and archive them one-by-one.
//
// 1. Go to https://chat.openai.com/
// 2. Open Chrome devtools (see https://developer.chrome.com/docs/devtools/open) or equivalent in your browser
// 3. Open the console tab
// 4. Paste the code below and press enter
const pause = (ms) => new Promise((resolve) => setTimeout(resolve, ms));
const history = document.querySelector('[aria-label="Chat history"]');
@trungdq88
trungdq88 / typingmind-extensions-model-search.js
Last active April 6, 2025 05:22
typingmind-extensions-model-search
/*
By kenharris from TypingMind Discord.
TypingMind Extension: Model Search & Full Model Names
Model Search Functionality: The model selector now includes a search
bar at the top. You can easily search and filter models by typing in
their names
@aomarks
aomarks / archive-all-chatgpt-chats.js
Last active February 13, 2025 22:42
Archive all ChatGPT chats browser script
// This script will iterate over all of your ChatGPT sessions and archive them one-by-one.
//
// 1. Go to https://chat.openai.com/
// 2. Open Chrome devtools (see https://developer.chrome.com/docs/devtools/open) or equivalent in your browser
// 3. Open the console tab
// 4. Paste the code below and press enter
const pause = (ms) => new Promise((resolve) => setTimeout(resolve, ms));
const history = document.querySelector('[aria-label="Chat history"]');
while (true) {
@bitmunja
bitmunja / chatgpt-width.user.js
Last active April 23, 2025 18:07
ChatGPT width
// ==UserScript==
// @name ChatGPT / Gemini / Claude Width
// @namespace http://tampermonkey.net/
// @version 0.10
// @description increase chatgpt, gemini and claude box width
// @author bitmunja
// @license MIT
// @match https://gemini.google.com/*
// @match https://chat.openai.com/*
// @match https://chatgpt.com/*
@fusetim
fusetim / protonvpn-wireguard-generator.py
Last active April 23, 2025 06:10
Generate lots of Wireguard configuration for your ProtonVPN Account.
import http.client
import http.cookies
import json
import base64
import hashlib
from cryptography.hazmat.primitives import serialization
from cryptography.hazmat.primitives.asymmetric import x25519
from cryptography.hazmat.primitives.asymmetric import ec
from cryptography.hazmat.primitives import hashes
@junebug12851
junebug12851 / readme.md
Last active March 21, 2025 01:26
Extract all Discord emojis and stickers from all servers

Important Note!

Doing this requires running a script inside Discord, historically Discord has allowed these perfectly fine but it was for advanced people only and Discod discovered non-advanced users were copying and pasting random scripts people gave them which ended up being malicious and harmful to their account.

Discord has since blocked access to scripts unless you enable a hidden setting. The script below is open source and commented. Anyone is welcome to verify the legitimacy of it. It's very simple in how it works. However if you proceed further and enable custom scripts, I highly reccomend to disable it afterwards unless you know what you are doing. There's a reason Discord disabled this feature, don't even run scripts without knowing what they do first.

/ip firewall filter
# INPUT - General
add action=accept chain=input comment="Allow 6to4" protocol=ipv6
add action=accept chain=input comment="Allow ICMP" protocol=icmp
add action=accept chain=input comment="Allow Broadcast" dst-address-type=broadcast
add action=accept chain=input comment="Allow local CAPsMAN" dst-address=127.0.0.1 dst-port=5246,5247 protocol=udp src-address=127.0.0.1
# INPUT - LAN Services
add action=jump chain=input comment="Jump to IN-LAN" rules" in-interface=bridge1-local jump-target=IN-LAN
@geerlingguy
geerlingguy / sbc-general-benchmark.sh
Last active February 14, 2025 20:27
SBC Benchmark Suite - Phoronix
#!/bin/bash
#
# Benchmark script for SBCs (Debian or Ubuntu).
#
# WARNING: This script is meant to be run as the root user.
# This script should never be run on a system/partition you
# care about. You should only run this on a system that you
# intend to use only for benchmarking and can reinstall or
# re-flash easily.
#
@dvf
dvf / change-codec.md
Last active April 24, 2025 04:55
Enable High Quality mode on your headphones (Updated for macOS Catalina)

If you're using a high-end bluetooth headset on your Macbook Pro it's likely your mac is using an audio codec which favors battery efficiency over high quality. This results in a drastic degradation of sound, the SBC codec is the likely culprit, read more about it here.

Find out what codec you're using

  1. Play a song on your headphones
  2. Option (⌥) click the Bluetooth button at the top of your screen Inspect the Bluetooth Coded
  3. If you're using AAC or aptX, you can stop here—those are the highest quality codecs.

Change your codec to AAC or aptX

@MineBartekSA
MineBartekSA / catbox
Last active April 19, 2025 15:24
CatBox - An implementation of catbox.moe API in Bash
#!/bin/bash
#
# CatBox v2.0
# An implementation of catbox.moe API in Bash
# Author: MineBartekSA
# Gist: https://gist.github.com/MineBartekSA/1d42d6973ddafb82793fd49b4fb06591
# Change log: https://gist.github.com/MineBartekSA/1d42d6973ddafb82793fd49b4fb06591?permalink_comment_id=4596132#gistcomment-4596132
#
# MIT License
#