Skip to content

Instantly share code, notes, and snippets.

@marfillaster
marfillaster / router.cfg
Last active November 7, 2024 01:35
MikroTik RouterOS v7 dual DHCP WAN recursive failover w/ PCC load-balancing; and recursive ECMP
# feb/11/2022 11:00:55 by RouterOS 7.2rc3
# software id = 9QK9-C798
#
# model = RB5009UG+S+
# serial number = XXXXXXXXXX
/ip settings set allow-fast-path=no
/interface bridge add admin-mac=FF:FF:FF:FF:FF:FF auto-mac=no name=bridge
@stevenma-code
stevenma-code / router.cfg
Created April 22, 2022 08:50
MikroTik RouterOS v7 dual DHCP WAN recursive failover w/ PCC load-balancing; and recursive ECMP router.cfg
# from: https://gist.github.com/marfillaster/7a136ea826815ac22f2849e099a1c6a1#file-router-cfg
# feb/11/2022 11:00:55 by RouterOS 7.2rc3
# software id = 9QK9-C798
#
# model = RB5009UG+S+
# serial number = XXXXXXXXXX
/ip settings set allow-fast-path=no
/interface bridge add admin-mac=FF:FF:FF:FF:FF:FF auto-mac=no name=bridge
@joeywas
joeywas / BufferBloatBegone.md
Last active December 12, 2023 20:08
Buffer Bloat Begone by implementing CAKE queue on RouterOS 7.3.1 on Mikrotik RB750Gr3

Buffer Bloat

Come aboard the Buffer Bloat Begone Boat and let us set sail for seas of lower latency under load!

The journey begins

I became interested in buffer bloat after watching a podcast interview with David Taht. At a friend's suggestion, I purchased an inexpensive Mikrotik RB750Gr3 device, in order to implement a more robust and fully featured network router for our home network

Equipment

We obtain internet via a Wireless ISP over a 5Ghz link to a tower 18 miles away, with a plan for 20Mbps/5Mbps. In reality, it's more like 13Mbps/4Mbps. The WISP modem is connected to an RB750Gr3 aka HEx, running RouterOS 7.3.1. Internal DNS and DHCP for the home network is provided by a pihole connected directly to the router.

@pojntfx
pojntfx / main.sh
Last active April 28, 2023 22:44
Build static cURL binary with HTTP/3 support
# Setup build environment
mkdir -p ~/Projects/curl-http3/prefix
cd ~/Projects/curl-http3
# Build OpenSSL with QUIC support
sudo dnf builddep -y openssl
rm -rf openssl
git clone https://github.com/quictls/openssl
cd openssl
git checkout openssl-3.0.0+quic