Created
August 10, 2013 06:53
-
-
Save jda/6199394 to your computer and use it in GitHub Desktop.
Basic config from a Cisco CSR1000V route reflector lab. Defaults except for IP config, usernames, login local, and very basic BGP config.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
! | |
version 15.3 | |
service timestamps debug datetime msec | |
service timestamps log datetime msec | |
no platform punt-keepalive disable-kernel-core | |
platform console virtual | |
! | |
hostname lab-vrr1 | |
! | |
boot-start-marker | |
boot-end-marker | |
! | |
! | |
vrf definition Mgmt-intf | |
! | |
address-family ipv4 | |
exit-address-family | |
! | |
address-family ipv6 | |
exit-address-family | |
! | |
enable secret REDACTED | |
! | |
no aaa new-model | |
! | |
! | |
! | |
! | |
! | |
ip domain name example.net | |
! | |
! | |
! | |
! | |
! | |
! | |
! | |
! | |
! | |
! | |
multilink bundle-name authenticated | |
! | |
! | |
! | |
username admin secret REDACTED | |
! | |
redundancy | |
mode none | |
! | |
! | |
! | |
ip tftp source-interface GigabitEthernet0 | |
! | |
! | |
! | |
! | |
interface GigabitEthernet1 | |
ip address 10.0.0.5 255.255.255.0 | |
negotiation auto | |
! | |
interface GigabitEthernet0 | |
vrf forwarding Mgmt-intf | |
no ip address | |
shutdown | |
negotiation auto | |
! | |
router bgp 64512 | |
bgp log-neighbor-changes | |
neighbor 10.0.0.1 remote-as 64512 | |
neighbor 10.0.0.1 description lab-master | |
! | |
address-family ipv4 | |
table-map nofib filter | |
neighbor 10.0.0.1 activate | |
neighbor 10.0.0.1 route-reflector-client | |
exit-address-family | |
! | |
! | |
virtual-service csr_mgmt | |
activate | |
! | |
ip forward-protocol nd | |
! | |
no ip http server | |
no ip http secure-server | |
ip route 0.0.0.0 0.0.0.0 10.0.0.1 | |
! | |
! | |
route-map nofib deny 10 | |
! | |
! | |
! | |
control-plane | |
! | |
! | |
line con 0 | |
stopbits 1 | |
line aux 0 | |
stopbits 1 | |
line vty 0 | |
login local | |
line vty 1 | |
login local | |
length 0 | |
line vty 2 4 | |
login local | |
line vty 5 15 | |
login local | |
! | |
onep | |
transport type tipc | |
! | |
end |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment