Created
March 26, 2012 23:19
-
-
Save jebaird/2210552 to your computer and use it in GitHub Desktop.
cisco 851w with wireless and port forwarding
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
! | |
version 12.3 | |
no service pad | |
service timestamps debug datetime msec | |
service timestamps log datetime msec | |
no service password-encryption | |
! | |
hostname yourname | |
! | |
boot-start-marker | |
boot-end-marker | |
! | |
logging buffered 52000 debugging | |
! | |
username admin privilege 15 secret 5 $1$mX47$C8OjHKi/j8ZmRgiGG4zpt1 | |
no aaa new-model | |
ip subnet-zero | |
ip cef | |
ip dhcp excluded-address 10.10.10.1 | |
ip dhcp excluded-address 192.168.0.1 192.168.0.10 | |
ip dhcp excluded-address 192.168.0.21 192.168.0.254 | |
! | |
ip dhcp pool sdm-pool | |
import all | |
network 10.10.10.0 255.255.255.248 | |
default-router 10.10.10.1 | |
lease 0 2 | |
! | |
ip dhcp pool sdm-pool1 | |
import all | |
network 192.168.0.0 255.255.255.0 | |
default-router 192.168.0.1 | |
! | |
! | |
no ftp-server write-enable | |
! | |
! | |
! | |
! | |
! | |
bridge irb | |
! | |
! | |
interface FastEthernet0 | |
no ip address | |
no cdp enable | |
! | |
interface FastEthernet1 | |
no ip address | |
no cdp enable | |
! | |
interface FastEthernet2 | |
no ip address | |
no cdp enable | |
! | |
interface FastEthernet3 | |
no ip address | |
no cdp enable | |
! | |
interface FastEthernet4 | |
description $ETH-LAN$ | |
ip address dhcp | |
ip nat outside | |
ip virtual-reassembly | |
duplex auto | |
speed auto | |
no cdp enable | |
! | |
interface Dot11Radio0 | |
no ip address | |
ip nat inside | |
ip virtual-reassembly | |
! | |
broadcast-key vlan 2 change 45 | |
! | |
broadcast-key vlan 1 change 45 | |
! | |
! | |
encryption vlan 2 mode ciphers tkip | |
! | |
encryption vlan 1 mode ciphers tkip | |
! | |
ssid yourssidhere | |
vlan 1 | |
authentication open | |
authentication key-management wpa | |
guest-mode | |
wpa-psk ascii 0 yourssidhere123 | |
! | |
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0 | |
rts threshold 2312 | |
station-role root | |
no cdp enable | |
! | |
interface Dot11Radio0.1 | |
description Cisco Open | |
no cdp enable | |
! | |
interface Dot11Radio0.2 | |
description closed private network | |
encapsulation dot1Q 1 native | |
no cdp enable | |
bridge-group 1 | |
bridge-group 1 subscriber-loop-control | |
bridge-group 1 spanning-disabled | |
bridge-group 1 block-unknown-source | |
no bridge-group 1 source-learning | |
no bridge-group 1 unicast-flooding | |
! | |
interface Vlan1 | |
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$ | |
no ip address | |
ip virtual-reassembly | |
bridge-group 1 | |
! | |
interface Vlan2 | |
no ip address | |
ip virtual-reassembly | |
bridge-group 1 | |
! | |
interface BVI1 | |
ip address 192.168.0.1 255.255.255.0 | |
ip nat inside | |
ip virtual-reassembly | |
! | |
ip classless | |
! | |
ip http server | |
ip http authentication local | |
ip http secure-server | |
ip http timeout-policy idle 5 life 86400 requests 10000 | |
ip nat pool dmz 192.168.0.5 192.168.0.5 netmask 255.255.255.0 type rotary | |
ip nat inside source list 1 interface FastEthernet4 overload | |
ip nat inside source static tcp 192.168.0.5 47624 interface FastEthernet4 47624 | |
ip nat inside destination list internet-inbound-acl pool dmz | |
! | |
ip access-list extended internet-inbound-acl | |
permit tcp any any eq 47624 | |
permit udp any any eq 47624 | |
permit udp any any range 2300 2400 | |
permit tcp any any range 2300 2400 | |
! | |
access-list 1 remark SDM_ACL Category=2 | |
access-list 1 permit 192.168.0.0 0.0.0.255 | |
no cdp run | |
! | |
control-plane | |
! | |
bridge 1 protocol ieee | |
bridge 1 route ip | |
banner login ^Celcome back Jesse! | |
^C | |
! | |
line con 0 | |
login local | |
no modem enable | |
transport preferred all | |
transport output all | |
line aux 0 | |
transport preferred all | |
transport output all | |
line vty 0 4 | |
privilege level 15 | |
login local | |
transport preferred all | |
transport input telnet ssh | |
transport output all | |
! | |
scheduler max-task-time 5000 | |
end |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment