We will tackle this process in 10 steps listed below.
I didn't want to repeat some sections well explained in the UEFI Process. You can refer there and follow due process.
Namely;
- Connecting to WiFi.
#!/bin/sh | |
# A modification of the standard Deno installation script (https://deno.land/install.sh) | |
# updated to support downloading a Linux arm64 binary from LukeChannings/deno-arm64 | |
set -e | |
if ! command -v unzip >/dev/null; then | |
echo "Error: unzip is required to install Deno (see: https://github.com/denoland/deno_install#unzip-is-required)." 1>&2 | |
exit 1 | |
fi |
{ | |
"compilerOptions": { | |
// project options | |
"lib": [ | |
"ESNext", | |
"dom" | |
], // specifies which default set of type definitions to use ("DOM", "ES6", etc) | |
"outDir": "lib", // .js (as well as .d.ts, .js.map, etc.) files will be emitted into this directory., | |
"removeComments": true, // Strips all comments from TypeScript files when converting into JavaScript- you rarely read compiled code so this saves space | |
"target": "ES6", // Target environment. Most modern browsers support ES6, but you may want to set it to newer or older. (defaults to ES3) |
We will tackle this process in 10 steps listed below.
I didn't want to repeat some sections well explained in the UEFI Process. You can refer there and follow due process.
Namely;
import XMonad | |
import XMonad.Config.Xfce | |
import XMonad.Hooks.ManageDocks | |
import XMonad.Hooks.EwmhDesktops | |
import XMonad.Hooks.SetWMName | |
import qualified Data.Map as M | |
import qualified XMonad.StackSet as W |
Seems to be also known as the HD18Q "black box". https://www.ebay.de/itm/153205410117 ("NEU MXQ S805 Smart 1GB+ 8GB Smart TV Box Android 4.4 Quad Core 1.5 G WIFI", seller "SILVESTRAS RUNTA Network Tech Co. Ltd"), EUR 14,99
I can boot with meson8b_m201d.dtb
and wired Ethernet works.
U-boot thinks it is a 512 MB device. Linux does, too. The SDK used seems to be named "s805_0701_512M":
root@vegas805:~# strings /mnt/lib/hw/camera.amlogic.so | grep home/
/metarouter interface add virtual-machine=mr1 type-dynamic dynamic-bridge=bridge
/metarouter console 0
root@OpenWrt:/# vi /etc/config/network
adb help // List all comands | |
== Adb Server | |
adb kill-server | |
adb start-server | |
== Adb Reboot | |
adb reboot | |
adb reboot recovery | |
adb reboot-bootloader |
/ip address | |
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local | |
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1 | |
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2 | |
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8,8.8.8.8 | |
/ip firewall mangle | |
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn | |
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn | |
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1 | |
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2 |
# All build snippets are based on Ubuntu trusty: | |
containers: | |
build: | |
setup: | |
- !Ubuntu trusty | |
- !UbuntuUniverse | |
# ------------------------------------------------------------------------ |