Skip to content

Instantly share code, notes, and snippets.

@kuyagic
kuyagic / cow
Created September 19, 2014 05:57
#!/bin/bash
### BEGIN INIT INFO
# Provides: cow
# Required-Start: $network
# Required-Stop: $network
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: COW: Climb Over the Wall http proxy
# Description: Automatically detect blocked site and use parent proxy.
### END INIT INFO
#block video ad
/ip firewall layer7-protocol
add name=youku-tudou regexp="^.+(v2html.atm.youku.com|atm.youku.com|ad.api.3g.tudou.com|ad.api.3g.youku.com).*\$"
add name=tencent regexp="^.+(fp.qq.com|rcgi.video.qq.com|tj.video.qq.com).*\$"
add name=iqiyi regexp="^.+(api.cupid.iqiyi.com).*\$"
add name=letv regexp="^.+(fz.letv.com|dc.letv.com|ark.letv.com).*\$"
add name=crossdomain regexp="^.+(crossdomain.xml).\$"
/ip firewall filter
add action=reject chain=forward comment="\CC\DA\D1\B6\CA\D3\C6\B5" layer7-protocol=tencent protocol=tcp reject-with=tcp-reset
@kuyagic
kuyagic / 0_reuse_code.js
Created April 21, 2016 02:31
Here are some things you can do with Gists in GistBox.
// Use Gists to store code you would like to remember later on
console.log(window); // log the "window" object to the console

Keybase proof

I hereby claim:

  • I am kuyagic on github.
  • I am kuyagic (https://keybase.io/kuyagic) on keybase.
  • I have a public key whose fingerprint is 318C 31EF 10B2 D373 DFAC DABD 899E DBC7 830E 0DA6

To claim this, I am signing this object:

2016-10新番組

  • ユーリON ICE
  • クズの本懐
  • ハンドシェイカー
  • ステラのまほう
  • うどんの国の金色毛鞠 bilibili
  • おくさまが生徒会長!二期
  • 舟を編む
  • 夏目友人帳.五期 bilibili
@kuyagic
kuyagic / uml-on-debian.md
Created February 19, 2017 05:41 — forked from gaoyifan/uml-on-debian.md
User Mode Linux on Debian Jessie

User Mode Linux on Debian Jessie

host kernel version: 3.16.36-1+deb8u2

target kernel version: 4.9-rc5

Build UML kernel

Preparation

[20170105][LKSUB]政宗くんのリベンジ
[20170107][LKSUB]亜人ちゃんは語りたい
[20170111][DMG]この素晴らしい世界に祝福を!2
[20170112][Sumisora]クズの本懐
[11/12]うらら迷路帖
[11/12]セイレン
[10/12]One Room
[11/12]CHAOS;CHILD
[11/13]AKIBA'S TRIP -THE ANIMATION-
[10/12]小林さんちのメイドラゴン

ベルセルク Ⅱ *

進撃の巨人Ⅱ *

冴えない彼女の育て方Ⅱ *

夏目友人帳六

ソード。オラトリア

@kuyagic
kuyagic / app.py
Created June 2, 2017 14:02 — forked from fanzeyi/app.py
Simple stream file proxy with Flask and Requests
# -*- coding: utf-8 -*-
from flask import Flask
from flask import Response
from flask import stream_with_context
import requests
app = Flask(__name__)
@kuyagic
kuyagic / config-sample.md
Last active December 18, 2017 10:19
Shadowsocks-libev sample config

Shadowsocks-libev 最新版配置样例

{
  "server": "0.0.0.0",
  "server_port": 443,
  "local_address": "0.0.0.0",
  "local_port": 1080,
  "password": "sample-password",
  "timeout": 60,
 "plugin": "obfs-local",