Created
July 5, 2016 21:43
-
-
Save lichti/ff02de4ef1e594c33b8cb9ba0f5f10b0 to your computer and use it in GitHub Desktop.
backup.mikrotik.script
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
:log info "backup beginning now"; | |
:local varEmail "[email protected]"; | |
:local varEmailSubj "Backup"; | |
:local Hostname [/system identity get name]; | |
:local varDate [/system clock get date]; | |
:local varMonth [:pick $varDate 0 3]; | |
:local varDay [:pick $varDate 4 6]; | |
:local varYear [:pick $varDate 7 11]; | |
:local varDateTime ([$varYear]."-".[$varMonth]."-".[$varDay]."-".[/system clock get time]); | |
:local subject ([/system identity get name] . " - " . [$varEmailSubj] . " - " . [$varDateTime]); | |
:local backupfile ([/system identity get name]. "-" . [$varDateTime]); | |
/system backup save name=$backupfile; | |
:delay 10s; | |
/tool e-mail send to=$varEmail subject=$subject file=$backupfile; | |
:log info "backup finished"; |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment