Skip to content

Instantly share code, notes, and snippets.

@lorentey
Last active July 8, 2018 12:20
Show Gist options
  • Save lorentey/d679064cb29df4558534d619319a1d9e to your computer and use it in GitHub Desktop.
Save lorentey/d679064cb29df4558534d619319a1d9e to your computer and use it in GitHub Desktop.
The most annoying thing about Swift 3's naming conventions is that some renamed members now shadow frequently used global functions:
extension Array where Element: Comparable {
func clamp(from lowerBound: Element, to upperBound: Element) -> Array {
return self.map { min(upperBound, max(lowerBound, $0)) }
}
}
let clamped = [0, 1, 2, 3, 4, 5, 6].clamp(from: 2, to: 4))
@resuna
Copy link

resuna commented Jun 30, 2016

Just got bit by this one.

Renaming “minElement” and “maxElement” to “min” and “max” was well-intentioned, but having to write Swift.min(Int, Int) is not an improvement.

Copy link

ghost commented Jul 8, 2018

extension Collection {
@inline(_always) public func max( x: T, _ y: T) -> T where T : Comparable { return Swift.max(x,y) }
@inline(_always) public func min( x: T, _ y: T) -> T where T : Comparable { return Swift.min(x,y) }
}

Seems to compile, but yuck.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment