This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# using curl -s https://gist.githubusercontent.com/mark99i/c2611df4a12ce1d048cd08fbc52f0002/raw/b8953281aece44d965ee244a3c42d7a28fe639dc/ubuntu-install-hyperv-addons.sh | bash | |
echo 'hv_vmbus' >> /etc/initramfs-tools/modules | |
echo 'hv_storvsc' >> /etc/initramfs-tools/modules | |
echo 'hv_blkvsc' >> /etc/initramfs-tools/modules | |
echo 'hv_netvsc' >> /etc/initramfs-tools/modules | |
apt update | |
apt -y install linux-virtual linux-cloud-tools-virtual linux-tools-virtual | |
update-initramfs -u |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
FROM python:3.12 | |
RUN mkdir /root/app | |
WORKDIR /root/app | |
ENV TZ Europe/Moscow | |
ENV PYTHONDONTWRITEBYTECODE 1 | |
ENV PYTHONUNBUFFERED 1 | |
RUN export PYTHONDONTWRITEBYTECODE=1 | |
RUN export PYTHONUNBUFFERED=1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
FROM debian:sid as openssl | |
RUN apt update | |
RUN apt install git nano build-essential checkinstall zlib1g-dev -y | |
RUN mkdir /root/openssl | |
WORKDIR /root/openssl | |
RUN git clone git://git.openssl.org/openssl.git . | |
RUN ./config --prefix=/usr/local/custom-openssl --openssldir=/etc/ssl | |
RUN make -j1 depend |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
if [ -z "$1" ] | |
then | |
echo "Select drive: $0 /dev/sdx" | |
exit 1 | |
fi | |
echo "" | |
drive_serial=$(hdparm -I $1 | grep 'Serial Number' | cut -d':' -f2 | xargs) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import os | |
folders: list[str] = os.listdir('./') | |
folders = list(filter(lambda fldr: not fldr.startswith('.') and os.path.isdir(fldr), folders)) | |
for folder in folders: | |
files: list[str] = os.listdir(folder) | |
files = list(filter(lambda f: f.endswith('.bru'), files)) | |
files = sorted(files) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import base64 | |
import json | |
import time | |
from hashlib import md5 | |
from urllib.parse import urlencode | |
from requests import get, post, put, Response | |
import jwt | |
class BaseRequest: | |
success: bool |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# aug/02/2020 20:44:33 by RouterOS 6.47.1 | |
# software id = Х | |
# | |
# model = 751G-2HnD | |
# serial number = Х | |
/interface bridge | |
add name=LAN-vSw protocol-mode=none | |
/interface wireless | |
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-XX \ | |
country=russia disabled=no frequency=2432 installation=indoor mode=\ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# | |
# Automatically generated file; DO NOT EDIT. | |
# Linux/arm64 5.3.5 Kernel Configuration | |
# | |
# | |
# Compiler: aarch64-linux-gnu-gcc (Ubuntu/Linaro 7.4.0-1ubuntu1~18.04.1) 7.4.0 | |
# | |
CONFIG_CC_IS_GCC=y | |
CONFIG_GCC_VERSION=70400 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
upstream php-handler { | |
server 127.0.0.1:9000; | |
# server unix:/var/run/php/php7.3-fpm.sock; | |
} | |
#server { | |
# listen 80; | |
# listen [::]:80; | |
# server_name cloud.mydomain.ru; | |
# принудительное использование https |