This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/usr/bin/env python | |
# copy https://raw.githubusercontent.com/cloudflare/cloudflare-blog/refs/heads/master/2017-06-29-ssdp/mmwatch | |
import sys | |
import time | |
import subprocess | |
import datetime | |
import re |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<?php | |
$encoded_string = "JATa2iUqVdzCkBP5RiyitlQlUiACl8UrpJOeGUJO"; | |
$cc_encryption_hash = "SOmECRAZYLONGHASHROFLCOPTERBBQKTHX"; | |
echo decrypt_whmcs($encoded_string, $cc_encryption_hash); | |
function decrypt_whmcs($encoded_string, $cc_encryption_hash) { | |
$key = md5(md5($cc_encryption_hash)) . md5($cc_encryption_hash); | |
$hash_key = _hash($key); | |
$hash_length = strlen($hash_key); |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Graphite monitoring | |
graphite = on | |
# Please use only IP because domain names are not allowed here | |
graphite_host = xxx.xxx.xxx.xxx | |
graphite_port = 9109 | |
# Default namespace for Graphite data | |
graphite_prefix = fastnetmon | |
# How often we export metrics to Graphite |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/interface wireless channels | |
add band=2ghz-b/g/n width=20 list=2GHz/20MHz frequency=2412 name=ch1 | |
add band=2ghz-b/g/n width=20 list=2GHz/20MHz frequency=2437 name=ch6 | |
add band=2ghz-b/g/n width=20 list=2GHz/20MHz frequency=2462 name=ch11 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=Ceee frequency=5180 name=ch36/38/42 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=eCee frequency=5200 name=ch40/38/42 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=eeCe frequency=5220 name=ch44/46/42 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=eeeC frequency=5240 name=ch48/46/42 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
NET=1.1.1.1 | |
tcpdump -i eth0 -n net $NET -G 1800 -w sip_dump_%d-%m-%y-%H-%M.pcap -v |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<blkiotune> | |
<device> | |
<path>/dev/vg/kvm980_img</path> | |
<read_iops_sec>100</read_iops_sec> | |
<write_iops_sec>100</write_iops_sec> | |
</device> | |
</blkiotune> |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
SOURCE="vds2" | |
SOURCE_LVM=$1 | |
DEST_LVM=$2 | |
SIZE=$3 | |
if [ "$SIZE" = "" ]; then | |
echo "Please specify size of lvm, example 32G" | |
exit |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
sed -i '/^LF_PERMBLOCK =/s/1/0/' /etc/csf/csf.conf | |
sed -i '/^CC_LOOKUPS =/s/CC_LOOKUPS.*/CC_LOOKUPS = "1"/' /etc/csf/csf.conf | |
sed -i '/^LF_TRIGGER =/s/LF_TRIGGER.*/LF_TRIGGER = "0"/' /etc/csf/csf.conf | |
sed -i '/^LF_TRIGGER_PERM =/s/LF_TRIGGER_PERM.*/LF_TRIGGER_PERM = "0"/' /etc/csf/csf.conf | |
sed -i '/^LF_EMAIL_ALERT =/s/LF_EMAIL_ALERT.*/LF_EMAIL_ALERT = "0"/' /etc/csf/csf.conf | |
sed -i '/^LF_SSHD =/s/LF_SSHD.*/LF_SSHD = "0"/' /etc/csf/csf.conf | |
sed -i '/^LF_FTPD =/s/LF_FTPD.*/LF_FTPD = "0"/' /etc/csf/csf.conf | |
sed -i '/^LF_SMTPAUTH =/s/LF_SMTPAUTH.*/LF_SMTPAUTH = "0"/' /etc/csf/csf.conf |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash -e | |
action=$1 | |
argument=$2 | |
IPS="1.1.1.1/24 2.2.2.2/24" | |
case "$action" in | |
listips) | |
#for i in $IPS; do |
NewerOlder