Skip to content

Instantly share code, notes, and snippets.

View nabakdev's full-sized avatar
💭
need vacation

nabak nabakdev

💭
need vacation
View GitHub Profile
@nabakdev
nabakdev / 15on16sepactivationguide.md
Created November 13, 2023 18:36 — forked from Orangera1n/15on16sepactivationguide.md
How to activate a device on iOS 15 that was futurerestored on 16 sep

whatisthisthisthisthisthisthis?

This is a guide on how to activate ur idevice on ios 15 (maybe ios 14 idk) when its futurerestored on 16 sep.

DISCLAIMER: I am very aware people might use this to bypass icloud, but I am NOT encouraging you to bypass icloud.

ALSO: THIS IS RECOMMENDED FOR ADVANCED USERS ONLY, i am not responsable for ur device being broken (tho idk how it becomes broken via this)

also, i've only tested this on macOS, might work on linux tho if u replace darwin with linux and shit.

@nabakdev
nabakdev / remove-close-button-firefox.md
Created September 27, 2023 13:53
Remove close button firefox

Remove close button firefox

Enable userChrome customization

  1. open firefox
  2. goto about:config
  3. set toolkit.legacyUserProfileCustomizations.stylesheets to true

Create the directory and its files

find the Profile Directory path on about:support

  1. create a new directory named chrome inside ``
@nabakdev
nabakdev / monitor.rsc
Last active August 30, 2023 09:48
mikrotik router OS script monitoring via telegram BOT
:local apiToken "xxx"
:local chatId "xxx"
:local pingit "10.10.10.1"
:local count 30
# ojo diganti
:local avgRtt;
:local pin
:local pout
// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
/*
* Copyright (c) 2018 Amlogic, Inc. All rights reserved.
* sibondt
*/
/dts-v1/;
#include "meson-g12a-u200.dts"
@nabakdev
nabakdev / clear-all-connections-ros.md
Created August 23, 2023 05:44
clear/remove/delete all connections on Router OS mikrotik

clear

/ip firewall connection remove [find]

clear with loop 3x

:for i from=1 to=3 do={ :do { /ip firewall connection remove [find] } on-error={ }; delay 1 }
@nabakdev
nabakdev / router-os-command-line-cheatsheet.md
Last active August 18, 2023 08:05
Router OS command line cheatsheet

find queue tree by name

/queue tree print where name=<queue-name>

edit queue tree by name

/queue tree set max-limit=50M <queue-name>

add scheduler

/system scheduler add name="super slow internet" start-time="11:30:00" interval=1d on-event={queue tree set limit-at=56k max-limit=56k }

@nabakdev
nabakdev / guide-change-imei-snapdragon.md
Created August 17, 2023 09:57
[GUIDE] How to change IMEI on Snapdragon devices

[GUIDE] How to change IMEI on Snapdragon devices

FOR EDUCATIONAL PURPOSE ONLY, CHANGING IMEI IS ILLEGAL IN MOST COUNTRIES, MAKE SURE YOU CONVINCE YOUR ACTIONS BEFORE DOING THIS.

I DON'T RESPONSIBLE IF YOUR DEVICE IS BROKEN OR THE IMEI IS NOT CHANGED CAUSED BY YOU DIDN'T FOLLOW THE STEPS CAREFULLY OR HAVING A DIFFERENT EFS PARTITION SCHEME.

This guide was tested on Google Pixel 3, different device may also have a different EFS partition scheme, please make sure you adjust it with this guide. Other Google Pixel devices may use this guide without adjusting.

Prerequisites:

@nabakdev
nabakdev / Dockerfile
Created August 2, 2023 10:58
Dockerized Nuxt.js with Chainguard distroless
# original template is from next.js example https://github.com/vercel/next.js/blob/canary/examples/with-docker/Dockerfile
#syntax=docker/dockerfile:1.4
FROM node:18-alpine AS base
# Install dependencies only when needed
FROM base AS deps
# Check https://github.com/nodejs/docker-node/tree/b4117f9333da4138b03a546ec926ef50a31506c3#nodealpine to understand why libc6-compat might be needed.
RUN apk add --no-cache libc6-compat
WORKDIR /app
@nabakdev
nabakdev / docker-compose.yml
Created July 10, 2023 08:51
filebrowser docker compose
version: '3'
services:
filebrowser:
image: filebrowser/filebrowser:s6
container_name: filebrowser
volumes:
- ./files:/srv
- ./config:/config
- ./database:/database
environment:
@nabakdev
nabakdev / disable-ipv6-openwrt.md
Created June 6, 2023 13:56
disable IPV6 openwrt
uci set 'network.lan.ipv6=0'
uci set 'network.wan.ipv6=0'
uci set 'dhcp.lan.dhcpv6=disabled'

# Disable RA and DHCPv6 so no IPv6 IPs are handed out
uci -q delete dhcp.lan.dhcpv6
uci -q delete dhcp.lan.ra

# Disable the LAN delegation