This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
function [resultado]=clasificar(muestra, centroides) | |
%% | |
% muestra de n X no_caracteristicas | |
% centroides de no_clases X no_caracteristicas | |
%% Clasificacion de muestras | |
% segun clustering usando KMEANS. | |
% Se requiere centroides eiquetados previamente | |
% es decir, un resultado 1 equivale a la clase 1 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
%% Control 2 EL4005 Principios de Comunicaciones | |
% Simulacion modulacion FM | |
clear; tic; kill; clc; | |
%% PARAMETROS | |
FRECUENCIA =500; | |
FRECUENCIAPOR =10e3; | |
PERIODO =1/FRECUENCIA; | |
PERIODOPOR =1/FRECUENCIAPOR; |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
function [resultado n]=fftsinglesideband(senal); | |
%% Funcion que retorna una FFT de Single Side | |
% ademas retorna n, la cantidad de puntos | |
% considerados para la FFT | |
% set de frecuencias se puede generar | |
% usando | |
% frecuencias =SAMPLING*(0:(n/2))/n; | |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Working with Altera Quartus II (Q2) and do proper versioning is not that easy | |
# but if you follow some rules it can be accomplished. :) | |
# This file should be placed into the main directory where the .qpf file is | |
# found. Generally Q2 throws all entities and so on in the main directory, but | |
# you can place all stuff also in separate folders. This approach is followed | |
# here. So when you create a new design create one or more folders where your | |
# entities will be located and put a .gitignore in there that overrides the | |
# ignores of this file, e.g. one single rule stating "!*" which allows now all | |
# type of files. When you add a MegaFunction or another entity to your design, | |
# simply add it to one of your private folders and Q2 will be happy and manage |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Show hidden characters
{ | |
"folders": | |
[ | |
{ | |
"file_include_patterns": | |
["*.v"], | |
"path": "." | |
} | |
] | |
} |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/** | |
Descripcion, | |
Modulo debouncer generico | |
----------------------------------------------------------------------------- | |
Author : Nicolas Hasbun | |
File : debouncer.v | |
Create : 2017-11-01 05:16:35 | |
Editor : sublime text3, tab size (2) | |
----------------------------------------------------------------------------- |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Hello, and welcome to makefile basics. | |
# | |
# You will learn why `make` is so great, and why, despite its "weird" syntax, | |
# it is actually a highly expressive, efficient, and powerful way to build | |
# programs. | |
# | |
# Once you're done here, go to | |
# http://www.gnu.org/software/make/manual/make.html | |
# to learn SOOOO much more. |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/ip firewall filter | |
add action=reject chain=forward comment="Reject MS Telemetry" \ | |
dst-address-list=MStelemetry reject-with=icmp-network-unreachable | |
/ip firewall address-list | |
add address=111.221.29.177 list=MStelemetry | |
add address=111.221.29.253 list=MStelemetry | |
add address=131.253.40.37 list=MStelemetry | |
add address=134.170.30.202 list=MStelemetry | |
add address=134.170.115.60 list=MStelemetry |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
@echo off | |
rem Altium Designer is quite invasive regarding file associations taking control all over the place. | |
rem This script put some stuff in place. | |
rem | |
rem assoc and ftype can be run standalone to get a list if you need to clean | |
rem more associations... | |
@echo on | |
assoc .asm= | |
assoc .c= |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#define BIT(x,n) (((x) >> (n)) & 1) | |
#define INSERT_BITS(original, mask, value, num) (original & (~mask)) | (value << num) | |
#ifdef __ASSEMBLY__ | |
#define CAST(type, value) value | |
#else | |
#define CAST(type, value) ((type)(value)) | |
#endif |
OlderNewer