Created
December 10, 2020 17:29
-
-
Save nikasepiskveradze/9db51bc37e1c87974528b7bc47b5268c to your computer and use it in GitHub Desktop.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import { useCallback, useState } from 'react'; | |
// Usage | |
function App() { | |
// Call the hook which returns, current value and the toggler function | |
const [isTextChanged, setIsTextChanged] = useToggle(); | |
return ( | |
<button onClick={setIsTextChanged}>{isTextChanged ? 'Toggled' : 'Click to Toggle'}</button> | |
); | |
} | |
// Hook | |
// Parameter is the boolean, with default "false" value | |
const useToggle = (initialState = false) => { | |
// Initialize the state | |
const [state, setState] = useState(initialState); | |
// Define and memorize toggler function in case we pass down the comopnent, | |
// This function change the boolean value to it's opposite value | |
const toggle = useCallback(() => setState(state => !state), []); | |
return [state, toggle] | |
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import { useCallback, useState } from 'react'; | |
// Usage | |
function App() { | |
// Call the hook which returns, current value and the toggler function | |
const [isTextChanged, setIsTextChanged] = useToggle(); | |
return ( | |
<button onClick={setIsTextChanged}>{isTextChanged ? 'Toggled' : 'Click to Toggle'}</button> | |
); | |
} | |
// Hook | |
// Parameter is the boolean, with default "false" value | |
const useToggle = (initialState: boolean = false): [boolean, any] => { | |
// Initialize the state | |
const [state, setState] = useState<boolean>(initialState); | |
// Define and memorize toggler function in case we pass down the comopnent, | |
// This function change the boolean value to it's opposite value | |
const toggle = useCallback((): void => setState(state => !state), []); | |
return [state, toggle] | |
} |
setIsTextChanged
is imo a bad name for toggler function. toggleIsTextChanged
would be better.
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
The typo,
comopnentcomponent, seems to be fixed in the .jsx, but not the .ts