Skip to content

Instantly share code, notes, and snippets.

@plembo
Last active June 17, 2024 17:23
Show Gist options
  • Save plembo/9287ea5cd187c4c650dd5afd15b2d768 to your computer and use it in GitHub Desktop.
Save plembo/9287ea5cd187c4c650dd5afd15b2d768 to your computer and use it in GitHub Desktop.
RouterOS Port Forward for Serviio

Port forwarding for Serviio with RouterOS

Some Pro subscription services for the Serviio media server require Internet access.

On a network protected by a Mikrotik RouterOS device, this will probably need to be set up manually.

In the examples below the IP address of your local Serviio box is 10.0.0.5 and the router's Internet port is "ether-gateway".

In the graphical console

  1. Go to IP... Firewall... NAT.

  2. Create new rule and enter the following parameters:

Chain: dstnat
protocol: 6 (tcp)
Dst. Port: 23424
In. Interface: ether-gateway
...

Action: dst-nat
To Addresses: 10.0.0.5
To Ports: 23424
...

Comment: NAT to Serviio server tcp (secure)
  1. Repeat for secure connections (port 23524).

  2. Verify rules are enabled.

  3. Go to Serviio console... Remote, and check Connectivity Status.

In the RouterOS ssh console

/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=10.0.0.5 to-ports=23424 protocol=tcp 
   in-interface=ether-gateway dst-port=23424

add chain=dstnat action=dst-nat to-addresses=10.0.0.5 to-ports=23524 protocol=tcp 
   in-interface=ether-gateway dst-port=23524

Host server firewall rules

If Serviio i running on a server with a host firewall (as it should), the following ports need to be open for it to work:

Port Purpose
23423/tcp console
23424/tcp mediabrowser
23524/tcp mediabrowser https
8895/tcp DLNA
1900/udp DLNA discovery
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment