Skip to content

Instantly share code, notes, and snippets.

@rikka0w0
Last active July 26, 2024 18:44
Show Gist options
  • Save rikka0w0/39c989ee8a541f531d63739bc82a47ed to your computer and use it in GitHub Desktop.
Save rikka0w0/39c989ee8a541f531d63739bc82a47ed to your computer and use it in GitHub Desktop.
Setup IPv6 Relay and IPv6 PxE (Co-exist) on OpenWrt

Some ISP only offer you a /64 prefix. If you want to add an OpenWrt router between the ISP router and your LAN while granting IPv6 access to LAN devices, you need relay. OpenWrt's built-in odhcpd(odhcp-ipv6only) can handle DHCPv6 relay. To enable this feature, you need to enable relay mode for ra and ndp for the wan6 (The upstream-facing IPv6 interface) and lan:

image image

Reboot your router and your LAN devices should get IPv6 addresses.

However, odhcpd supports neither custom DHCP options nor PxE. We need to use dnsmasq. The slim version in the default OpenWrt installation wont work, you need to remove it and install the full version:

opkg update
opkg remove dnsmasq
opkg install dnsmasq-full

After you install dnsmasq-full, you wont notice any difference. Because the startup script of dnsmasq disables dnsmasq's IPv6 handling if odhcpd exists and has been enabled. The challenge now becomes how to run both in parallel. We want to use dnsmasq for DHCPv6 and PxE, and odhcpd for everything else related to IPv6.

You now need to create a new interface in luci. The protocol is static address, the device must be set to the same as the lan interface. Leave the IPv4 settings unpopulated and untouched. In the Advanced Settings tab, set IPv6 assignment length to 64 and IPv6 prefix filter to local (Local ULA). Then, set the firewall-zone to lan. Finally, go to the DHCP Server tab, simplify click the button to create a DHCP server, make sure the RA-Service, DHCPv6-Service, and NDP-Proxy are all set to disabled: image

Since odhcpd directly read options from /etc/config/dhcp, this should convience odhcpd not to start a DHCPv6 server on the lan interface. It is critical that odhcpd only performs RA and NDP relay.

To run dnsmasq's DHCPv6 server, you need to manually add this dhcp-range=set:lan,::1000,::ffff,constructor:br-lan,12h to /etc/dnsmasq.conf, where br-lan is the device of interface lan. In addition, add PxE related options.

If you want to enabel SLAAC on lan2, the modification to /etc/dnsmasq.conf should be:

ra-param=br-lan.1,0,7200
dhcp-range=set:lan,::1000,::ffff,constructor:br-lan,slaac,ra-names,12h
dhcp-option=lan,option6:dns-server,[::]

After rebooting, IPv6 PxE should work.

Important fields in /etc/config/dhcp:

config dhcp 'wan6'
	option interface 'wan6'
	option master '1'
>	option ra 'relay'
>	option dhcpv6 'relay'
>	option ndp 'relay'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
>	option ra 'relay'
>	option ndp 'relay'

Important fields in /etc/config/network:

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.114.1'
	option netmask '255.255.255.0'
>	# In this example, there is no need to have IPv6 stuff here

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'eth1'
>	option reqaddress 'try'
>	option reqprefix '64'

config interface 'lan2'
	option proto 'static'
	option device 'br-lan.1'
>	option ip6assign '64'
>	list ip6class 'local'

Check if odhcpd is running and verify the owner of port 547 (DHCPv6), should be dnsmasq.

root@OpenWrt:~# ps | grep odhcpd
 1598 root      1128 S    /usr/sbin/odhcpd
root@OpenWrt:~# netstat -lunp | grep :::54
udp        0      0 :::546                  :::*                                1488/odhcp6c
udp        0      0 :::547                  :::*                                2634/dnsmasq
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment